I have an ASUS Q550LF running Windows 10; recently, I noticed that my NVidia GeForce 745m has been stopped (in the Device Manager). The error code is.

Windows has stopped this device because it has reported problems. (Code 43)

First thing I did was disable and enable it manually; still had the same error code.

I ran through all my windows updates, all my NVidia updates. Then I cleared all the NVidia drivers and reinstalled them to see if that would do the trick; it did not. I checked my BIOS, as I had read on an article that Windows 10 and my laptop do not play well; my current BIOS version is 215 so I saw no need to flash it to a previous version.

I finally thought that maybe I should wipe my SSD and see if that would produce any results. After wiping the SSD and installing the latest drivers (Using GeForce Experience), I still see the same message when I look at my GPU in 'Device Manager'.

I'm beginning to wonder if my GPU is toasted; last time I played a game on it was two months ago (Battlefront). I was running on low settings and while the machine was warm, it wasn't any warmer than when I play any other games.

What else should I try in order to determine the root cause of my GPU being disabled?

  • 1
    Try it on another (live) OS like Ubuntu to see if it is toast? – ss4566654768 Jan 9 '16 at 23:51

I saw in another thread a solution that helped me with this issue:

  1. You have to turn off your laptop.

  2. Press the power button for 1 minute, your computer will turn on briefly and off again. Just keep holding the button.

  3. Turn it on normally, if it isn't fixed just disable it and enable it from device manager.

Hope it helps.

  • This might have been easier than my solution. I'd be interested to see if someone else tried this solution and if it worked for them. – sparkyShorts Feb 8 '16 at 17:47
  • 1
    @sparkyShorts it does work! – UmNyobe Apr 27 '16 at 2:13
  • I'll mark this as the selected answer then. To future users, try my solution if this doesn't do the trick. – sparkyShorts Apr 27 '16 at 2:15

A few people are reporting issues with this notebook and Windows 10. Try a clean install of Windows 7 or 8/8.1 temporarily and see if the device driver works. Before you do this, you can also try resetting the bios to defaults and checking for an update.

Just found this link to another q550lf user, and this includes a possible fix.



I took my laptop apart last night and disconnected the battery from the motherboard. I then reconnected it and booted up. I checked my device manager and saw that my NVidia 745m *still* had code 43.

I disabled and then re-enabled the device and it has come back! No more errors, I've rebooted several times and have done some other testing to ensure that it was still working and thus far, it is.

Here's a link to Q550LF Dis-assembly


It's been a few weeks and everything appears to be working well. It crashed on me once, but has held up to Fallout 4, Diablo 3, and some Battlefront.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.