I just rebooted my system after a week and now whenever i boot it up i am directed to the same login screen however i can no longer log in. I didn't have any password on my account so used to hit enter to login but now it just reloads the same login screen again. I cannot login with any other user because i don't have any other and login with root isn't allows. Moreover whenever i try to log in through terminal with root, it shows the last login time for an instant and then restart the session and asks me for my password again. Any help would be appreciated.

  • What Fedora version is this? Do you have a Rescue option in the initial boot menu?
    – mattdm
    Jan 13, 2016 at 3:19
  • rescue option boots into identical OS (same bug) so do all the other 3 fedora instances.I am running fedora 23 workstation edition, kernel 4.2.8-300.fc23.x84_64 running GNOME. live cd rescue doesnt work because it asks for a password for root in rescue mode which doesnt work. Moreover single user mode doesnt work and neither does manually mounting the partition in live cd
    – pranay
    Jan 13, 2016 at 11:03
  • see here:ask.fedoraproject.org/en/question/81179/… for more steps i have tried
    – pranay
    Jan 13, 2016 at 11:10
  • How did you get into a state with no password on the account?
    – mattdm
    Dec 13, 2016 at 17:16
  • @mattdm I think it happened when I was working in Su mode and had an unexpected shutdown, so the permissions did not revert to my account. This did happen to me again after a kernel panic.
    – pranay
    Dec 13, 2016 at 17:20

9 Answers 9


If anyone else has had this problem, this is how I fixed mine.

  1. Choose login with another user and login as root (logging in through the shell didn't work for me).
  2. Open terminal and give access to your user account for the home directory using chown username /home/username
  3. Try logging in again. If it still fails, give you account access to the /root directory and any other directory that your account might have been using.
  4. If you can't login with root in the another user option then try using sudo to run the command in the shell with your account.
  5. A final thing you could do is connect your hard drive to another computer, copy the /home partition there and then delete it. After rebooting now you should be able to login as root and make a new /home partition.

I finally fixed this problem when it happened to me a second time (4 months later). It seems the problem was an unscheduled shutdown while using sudo or logged in as root on the terminal. Access problems could also have something to do with why I couldn't login in the shell.

Hope this helps

  • This answer seems to revolve around being able to log in as root somehow, and running the chown command. I am on F24 Workstation, and am currently experiencing this problem. I may have had an unexpected shutdown. The permissions on the user account's home directory seem to be 700, and owned by that user. I have run the recursive command as per ask.fedoraproject.org/en/question/53638/f19-stuck-in-login-loop/…, restarted, and still looping back to the log in screen. Am I missing anything? The password works, and I'm in SSH, just the looping problem..
    – Pysis
    Dec 1, 2016 at 2:56
  • @Pysis If you can login as another user, try moving the home directory elsewhere and deleting that user. Then, make another one and restore your home data. Otherwise, what I did was not a restart but a logout when I change the permissions. Also try using an older fedora image. If your problem persists make another question somewhere with your particular question and logs.
    – pranay
    Dec 4, 2016 at 4:59

I had the same problem and it turns out my .bashrc was the culprit. To fix it, from the login screen I hit Ctrl+Alt+F2 to get to terminal, then vi ~/.bashrc and comment out anything you think could be causing a problem. For me it was a few lines that had tmux start automatically with a new terminal window. Then type reboot to restart your computer and get back to the login screen.

Hope this helps anyone who had the same problem as me.


This is not a fix, and it is only a temporary solution and it seems so un-legitimate that it might not work for everyone (beside me).

I've rebooted a few times like this and it works. One day i was raging at the loggind so i just started to click everywhere with my mouse and got in.

So, Select yourself in the menu, enter your password and press enter. The micro second you've press enter, start clicking anywhere with your mouse.

  • Actualy i figured you need to click in the gray in the fadding 'window' frame. Aka, from the moment it start to fadeout, and the moment it finnises fading. Sometimes takes me a few tries but always end up logging in before getting pissed. Mar 8, 2017 at 5:50

I had the same problem.

I disabled Wayland completely in '/etc/gdm/custom.conf', By Uncommenting the line # WaylandEnable=false


And work for me.

  • Does F24 even have wayland?
    – Journeyman Geek
    Mar 3, 2017 at 5:35
  • Sorry, I have Fedora 25, Fedora 24 not have wayland as default display driver
    – user703480
    Mar 4, 2017 at 6:58
  • This worked for me with F31... tried several things, this is a fresh install. After just one update couldn't login :/ frustrating! Feb 1, 2020 at 11:03

Once you start typing your password, you can see a settings gear pop up next to the Login button. If you click it, you can choose what desktop to use. The standard gnome won't work on mine but the Gnome on Xorg option works fine. It may be a display driver issue.

  • Welcome to Superuser. You should take the tour at superuser.com/Tour to get the most out of this site.
    – SDsolar
    Jun 16, 2017 at 0:54

Same problem here. Installed Fedora 27 over Fedora 28. Moved /home partition to old partition where all mys users were. At firt login,ok.Then logout and try to login back=> loop.


In my case I was trying to install Quartus on my machine, and had inserted some new entries in the .bashrc file. Then the problem. So I booted in a live session and edited the .bashrc file removing the entries that I had inserted before, then it logged successfully.


If you have old .tcshrc & .cshrc startup files, you may have this line in your startup:

setenv DISPLAY :0

That line causes the login loop, with Wayland + Gnome on Fedora 33. Comment that line out & see if your login loop goes away.


[CTRL] [Alt] F2

move /user_director /user_directory_OLD [CTRL] [ALT] F1


Copy any need files/folder to new home dir.

*** having trouble with this, then do it as root and change ownership to the user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.