37

I have 2 languages installed on my computer, both with a single input method.

I have 2 keyboards: CES-CSQ and ENG-US.

enter image description here

However lately (maybe after the last Win10 update) I started to see 2 additional keyboards in my systray - namely CES-CS and ENG-CSQ.

enter image description here

Is there there a way to remove those 2 input options (CES-CS, ENG-CSQ) which I do not see in the Control panel's Language options?

Solution described at How to delete a keyboard in Windows 10 question does not apply to my problem because I do not see input options that I want remove in Control panel's Language options.

| |
  • 2
    Possible duplicate of How to delete a keyboard in Windows 10 – DavidPostill Jan 12 '16 at 8:57
  • 1
    @DavidPostill: I do not think it is a duplicate - please see the explanation I added at the end of my post. – Jan Palas Jan 12 '16 at 9:14
  • 1
    OK. Dupe VTC removed. – DavidPostill Jan 12 '16 at 9:16
  • @JanPalas, I see you have accepted one of the answers, but what about the part prevent them from coming back? Was this resolved? I have used the trick from the answers below, but if I restart Windows, the default Windows language is always added anew, and I have to do it all over again. – Richard Hardy Jan 26 '18 at 9:48
  • @RichardHardy The part prevent them from coming back was added to the question title few weeks ago by an editor (@Romain Vincent). I did not have problems with keybourd input options coming back at the time I asked this question - the original title was "How to delete a keyboard input option in Windows 10" (which was more appropriate in my opinion). – Jan Palas Jan 26 '18 at 20:36
43

(Credits to Jonno whose answer led me to the solution)

Go to systray and open Language preferences. Click Options for each language that has an extra kayboard that you want to remove.

In Keyboards section click Add a keyboard and select a keyboard that appears in your systray and which you want to remove. This adds a new input option for the selected language. After you add the keyboard, click it and click on a Remove button. After that, the keyboard should disappear also from systray.

(Note that I did not see a keyboard which I want remove in Keyboards section thus I had to add it first to be able to remove it afterwards.)

EDIT: bugybunny's answer helped me to prevent keyboard layouts from magically appearing whenever I connected to my PC via remote desktop (which they regularly did).

| |
  • 1
    Stupid that we have to add something before we can delete it... This solution worked for my Swedish keyboard (English version of Windows) – Hauns TM Nov 9 '16 at 12:41
  • 2
    It sometimes comes back after relogging, so not a full solution – htmlcoderexe Mar 21 '18 at 15:41
13

I've duplicated your issue, it's quite simple to fix (Ignore my ENG keyboard layout):

enter image description here

Click Language Preferences

enter image description here

Click United States - then Options

This keyboard (Czech - QWERTY) is your ENG - CSQ, remove it.

enter image description here

Go back, go to options for Čeština

enter image description here

Remove Czech - QWERTZ -> This is CES - CS

enter image description here

This should now be back as you wanted. The languages are the parent of the keyboards, you can specify different keyboard layouts per language.

enter image description here

Edit: It seems that if these keyboards don't exist in these pages, adding them and then removing them resolves the issue.

| |
  • 4
    Thank you, however the problem is that I do not see Czech - QWERTY under United States (and CZECH - QWERTZ under Čeština), thus I cannot remove them. But your post lead to the solution of my problem - firstly I added those 2 keyboards and then I removed them. And everything is as it should be now - I have only 2 keyboards. – Jan Palas Jan 12 '16 at 9:34
  • @JanPalas Very strange, but glad you found a solution. – Jonno Jan 12 '16 at 9:37
9

Note: I just switched from de_DE to de_CH and had to repeat the steps. So this has to be done every time you add a new layout and switch to it.

Answer is similar to @berm’s one. Just as info: I have Windows 10 (1903 at the moment but had the problem for many many builds since I‘ve switched to Windows 10) with German (Germany) keyboard layout added under the language English (United States) which is also my Windows display language. Regional format is German (Switzerland). Windows kept adding the layouts

  • English (US)
  • German (Switzerland)
  • French (Switzerland)

Now for the fix. Go to Welcome screen and new user account settings.

This might differ from build to build but I could get it under Windows 10, 1903 by

  1. Opening the Control Panel,
  2. Click on Region Region settings
  3. Switch to tab Administrative in the now opened dialog
  4. Click on button Copy settings… Region -> Administrative

Welcome screen and new user account settings dialog will open. Then follow these steps

  1. Check both boxes at the bottom of the dialog Welcome screen and new user account settings dialog

  2. Restart (log off and log in again might be enough, would restart to be safe). IIRC Windows will tell you about restarting if this setting differs from the current one, which was the case for me.

  3. After the restart, Windows added the unwanted layouts again. Follow @Jan Palas‘ answer on how to remove them again by adding them and deleting them.

  4. Restart again or log off/log in again

  5. Profit and hopefully have a not so crappy Windows anymore. Haven‘t had the problem for almost a week now which is a miracle.

| |
  • 3
    Perfect! Magically appearing keyboard layout have been bugging me for years. They appeared whenever I connected to my PC via remote desktop. After that I had to remove them as I described in my answer. However after following your guide, they did not appear after connecting via RD. Hope it will last :-) I am going to edit my answer to refer to your answer. – Jan Palas Oct 22 '19 at 6:23
4

Try this. At least it's work for me.

https://it42.cc/2018/11/04/windows-10-unwanted-keyboard-layout-fixed/

In order to fix this problem you have to do following steps:

Go to setting > Time & Language > Region & Language > Administrative language setting Under Welcome screen and new user accounts make sure that there are no extra keyboard layout appear in the list Click OK and Restart PC. This should fix your problem.

| |
  • 1
    Welcome to Super User. Few hints: Posting the same answer with the same link under multiple questions may be seen as spam. If your answer applies for more than one question then maybe these questions are duplicates; in such case it's better to flag questions as such. At the moment you don't have enough reputation to flag, still posting the same answer is not a good idea. – Kamil Maciorowski Nov 4 '18 at 21:57
  • This is the one correct answer. All the others are only workarounds until the unwanted layout comes again. – Arturo Torres Sánchez Sep 26 '19 at 1:48
4

I'm struggling with the same issue. I tried following step-by-step all the solutions provided in the other answers but after a reboot the unwanted keyboard layouts are added back. In my opinion, this is 99,99% a Windows bug that Microsoft needs to fix.

There are 2 new workarounds that I just found about and I would like to share:

  1. Delete the HKEY_USERS\.DEFAULT\Keyboard Layout\Preload registry key and reboot or sign out.

    This registry key seems to be some sort of a legacy remnant that contains non-user-specified keyboard layouts to be added to the list of languages when the user signs in. While the fix itself persists through restarts, there's a few things that seem to bring back the deleted entry:

    1. Connecting through Remote Desktop to a computer with US layout
    2. Applying the Windows 10 Anniversary update
    3. Logging-in with the same Microsoft account on another PC that still has this issue

    Therefore, whenever the problem comes back, the above-mentioned registry key needs to be deleted again.

    Edit: I have created a RemovePreload.reg text file with the following content, so that the fix can be easily re-applied without navigating the registry:

    Windows Registry Editor Version 5.00
    
    [-HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
    

    To use it, save it in a text file and change the extension from .txt to .reg. Then whenever the issue comes back, you can just double click it and then restart or sign out.

  2. Delete any unneeded language files from C:\Windows\System32, such as KBDUS.DLL or others.

| |
  • This is a great solution, however the registry key keeps coming back. I found out that setting permissions on this key to DENY for Everyone + two other "weird" accounts and then yourself as ALLOW worked and the problem stopped appearing altogether. – Miloš Nov 7 '18 at 15:59
0

You have to disable language preferences as well, then adding/removing keyboard layout will work.

| |
0

For my case, I tried all the above methods and it keeps coming back. I get it working by installing CCleaner Free version, then click -> Registry on the left, then-> scan for issues -> fix issues-> restart your PC. It should solve the problem.

| |
0

Late answer but maybe is still usefull.

I went trought the same problem in already 2 PC's, in both I solved it deleting the registry for the keyboard layout causing the problem. No serious consequence in any of them untill now.

  1. Backup. Make sure to have a backup of your PC, at leats of your Registry, you could damage your system doing this.
  2. Registry. Open your registry (Win + R, regedit.msc) and search HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\.
  3. Key. You have find and delete the value of the Keyboard Layout that dont want to use. Example: 00000409 = en_US.
  4. Delete. Before you delete it, you can click File then Export to save the key values.
  5. Reboot. After reboot check if the deleted key dont show up at the Add a Keyboard list in the Language options is your Settings menu. If is still there, you deleted the incorrect, restore the registry backup and repeat.

This is the only way I found to stop the keboard layout from show up permanently, and again I have no problem so far, be carefull anyway.

| |
  • That's removing a system-wide value by the way, not just for a user. – amn Mar 1 at 15:57
-1

Most of the people likes to delete the default keyboard of the operating system and they cannot find it in the control panel. The secrete is to change the "Current language for non-Unicode programs". Check the Administrative tab of the Region in the control panel.

| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.