1

I am having this weird issue with my laptop. It only happens when I put my laptop to sleep or hibernation. After resuming Windows I couldn't connect to WiFi anymore. When I try to connect it takes a few minutes and then I get the message "Can't connect to this network".

Every-time, I have to reboot my system to make it functional.

Previously, I had Windows 8. So I thought there must be some issue on the OS but now I installed Windows 10 are formatting the system. The problem still exist. Any possible reasons why?

I've Intel(R) PRO/Wireless 3945ABG Network Connection and Windows 10 Pro

  • Probably a driver issue, have you installed the latest Intel wifi driver? Use auto detect feature...downloadcenter.intel.com – Moab Jan 12 '16 at 16:45
  • 1
    Its not officially supported in Windows 10...communities.intel.com/thread/77854?start=0 – Moab Jan 12 '16 at 16:47
  • @Moab - The issue occurred in Windows 8 too. However, the issue is same which you mentioned in the link. But wondering why is it happening? – Kunal Jan 12 '16 at 17:06
  • Its a buggy driver that Intel never fixed. – Moab Jan 12 '16 at 17:36
0

The reason is probably the driver that isn't fully compatible with the OS, as Moab just pointed in the comments. There's always a chance that old drivers may not work with new OS. Maybe you can try go to Control Panel\Network and Internet\Network Connections, right-click the one that corresponds to your adapter > Properties > Configure > Power Management > Uncheck "Allow this computer to turn off this device to save power" and then go OK and see if it works. Unfortunately, without Intel fixing the drive there is not much you can do about it rather than doing some workarounds:

  1. Identify the wireless network card to “reset”

    • [Win] + W > Type Windows powershell + [Enter]

    • Type Get-NetAdapter + [Enter] at the Powershell prompt Next to Wi-Fi in the Name column you get the InterfaceDescription string of your wireless adapter (Intel(R) Wireless… in this case):

  2. Create the shortcut

    • Go to the Desktop > Right-click > New > Shortcut

    • Type powershell.exe restart-netadapter -InterfaceDescription 'xxxxxx' -Confirm:$false xxxxxx must be replaced with the InterfaceDescription string read in #1. In this case this would give:

      powershell.exe restart-netadapter -InterfaceDescription 'Intel(R) Wireless WiFi Link 4965AGN' -Confirm:$false

    • Click Next > Give it a name, i.e. Reset my Wi-Fi card > Click Finish Right-click on the shortcut > Properties > Advanced… (button) > Check option Run as administrator > OK twice

  3. Pin the shortcut

    • Right-click on the shortcut > Pin to Start and/or Pin to Taskbar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.