I want to use boot-repair-disk on my pc. This is a program that is previously burned in a removable media such as CD/DVD/USB stick, and then you boot on it (power off the computer, press the BIOS menu and select the media to boot from there).

Justification Why I need this program to boot: It's a recommended tool for fixing problems of booting, for recovering the system, and for uninstalling OS Ubuntu (what I want to do) it's the recommended way. By the way, Ubuntu it's totally corrupted, I can't boot in it and uninstall from it, because it crashes and the only way out is removing the battery, Ubuntu got corrupted during a update error.

So the situation is this: I downloaded iso for Boot repair disk 64, which is linked in the Ubuntu article from before, and in that article it very clearly says can be written in usb sticks, and also in this instructions from above. I'm insisting on this point because the program is called boot repair disk but of course that's only the name.

I wrote that image into usb-sticks three times with different burners and into two different usb sticks, in all attempts followed this procedure, wich has worked other times with different images (that were Ubuntu 14.04 LTS 64 bit and Debian Jessie 8 64bit), the procedure which is the normal one is: Powering off, inserting usb stick, power on, change boot order to give priority to usb stick, and save changes. And the it boots from the hard drive into the normal GRUB2, like it couldn't boot from usb stick and resorts to the next option, wich is the Hard drive. So I can't use the program. There is not any text or log showing any error or failure, it just ignores it.

I tried burning from Windows with Win32 disk imager and Unetbotin, and from Linux (debian) with command line way, like this (has worked fine before)

For some reason I can't boot from this one. I think maybe it's not a hybrid ISO image, but I don't have sufficient knowledge about that... But I did saw this question, and did the first answer recommendation and in fact it seems like this image wasn't recognized the same way as another one (the Ubuntu one). The Ubuntu one displayed a big output with many options, the image I want to boot displayed a error.

Edit: I forgot to say that it actually boots from a cd r, written with brasero on linux debian. But I still have reasons for wanting it from usb stick, one of them it's slow and cd it's scratched, so it may crash, wich is dangerous because it's a session live from a cd, the only way out is removing power ( the batterie).


2 Answers 2


Hi (forgive for my poor English ;-) , I'm from Italy)


I use Boot Repair Disk 64 bit in a multiboot on Yumi (Windows version) and it seems to work fine. I recently lost GRUB on my Win7/Mint dual boot, so only Windows could boot. I ran BRD, clicked on one-click recommended fix option and GRUB was back again. Yumi is a great tool (recently updated and fixed). You can try dd tool too, but be careful: it can be a tricky tool if you're not experienced with it and command line in general. Rufus is a great tool as well (even better than Yumi if you want to burn only one ISO) and it works fine with BRD: in addition on Rufus you can change the partition scheme and target system type: BIOS, UEFI, MBR, GPT...

Good luck and let me know if you succeeded!


  • DD won't work because that is a copying command, and the ISO is not a hybrid, as checked by me in the question and the other commenter. I'll try Rufus and Yumi, but it will be the last attempt since I tried many programs already. Jan 13, 2016 at 17:18
  • Rufus worked on Windows to write the ISO ! I was in despair because UNetBootin wouldn't work, and everyone recommended it... Probably Unetbootin didn't format FAT 32 before and Rufus did ? That's only a guess. I haven't tried Yumi yet, but thanks for the program, it actually solved the problem. Oh, and sorry for my english too! Jan 13, 2016 at 18:28

I checked the ISO, it is not a hybrid. So an image burn won't work, you need either 1) a tool that will make it bootable (unetbootin should do it?) or 2) a smart BIOS that will recognize the USB stick. Try formatting it as FAT32 and just copying the files from inside the ISO to it

  • Yes it is not a hybrid, so DD and CP commands are expected to not work, I realize that now. How did you checked it wasn't hybrid, using [this question][superuser.com/questions/683210/…? I already in the question said Unetbootin doesn't work even if it's the preferred option. I tried moba live from Windows and in fact the pen drive booted, it is a virtuali machine. Jan 13, 2016 at 17:12
  • @jiggunger Formatting FAT32 and copying will not work since it is not a hybrid image ISO. They need Unetbootin or Rufus to work. [This debian help][debian.org/releases/stable/amd64/ch04s03.html.en] says that since now Debian distros are hybrid, they can be written directly without a special program. Jan 13, 2016 at 17:17
  • 1
    @Santropedro you don't understand, copying the files is unrelated to the bootability of the ISO. By formatting it to FAT32 you create an MBR, which is absent in the ISO. My suggestion relies (hopes) on the default MBR or BIOS to handle stage 1 bootloading. Also I checked the ISO by reading the first 512 bytes (all zero) so theres no MBR on the ISO. dd is different, don't use that, it copies the sectors--you just want the files.
    – jiggunjer
    Jan 14, 2016 at 1:51
  • 1
    I added my checking method as an answer in that link. I learned most computer science stuff from wikipedia and various unix-related websites. And yes, copying with cp 'converts' the files to the target (i.e. FAT32) filesystem.
    – jiggunjer
    Jan 14, 2016 at 3:16
  • 1
    – jiggunjer
    Jan 14, 2016 at 4:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .