15

In Windows 10, there's the option to turn off autocorrection of spelling errors in "Settings - Devices - Input". In Windows 10 Mail, you can also disable the highlighting and autocorrection of spelling errors when writing an e-mail in the options menu. Still, the autocorrection will be "correcting" errors on its own, which is even more annoying when you're writing in a language Win10 doesn't understand.

I presume that the spell check is somehow integrated into the keyboard language, but only active within some applications (maybe those that don't appropriately control it). I have several different languages installed, with German being the main one, but no English keyboard installed, as it is simply not neccessary when using the german one (no additional keys/letters in English, and I prefer the language list not to get too long). Now when writing a mail in English, it autocorrects everything german-style (in Mail). Within the keyboard settings (control panel - time, language and region - language - keyboard=>options) I have access to some details regarding the spell checking (differently for different keyboard languages), but no option whatsoever to just turn it off! Regardless of me using a german layout for english input, there should be an option for anyone not wanting a spell check to turn it off, shouldn't it?

Does anybody have a clue whether there is another hidden option for spelling checks which could really turn this thing off?

  • 3
    Same situation here. – playcat Jan 29 '16 at 11:11
4

This is an old question but this might be the right answer.

The reasoning: Seems that group policies take precedency over user Settings.

What worked for me:

  1. open the gpedit.msc (just type into the search/Cortana and click the first option)
  2. go to User Configuration > Administrative Templates > Control Panel > Regional and Language Options
  3. Enable both Turn off autocorrect... and Turn off highlight...

enter image description here

  • Microsoft gets really good at maddening its users... I have turned off everything I can (and they add more options to this anti-feature regularly, forcing you to check them again at major updates), but it keeps changing my words into completely unintended ones, even when I am typing in my default language. (The I in AI is actually a joke. Or an insult to intelligence.) Unfortunately for me, gpedit changes are ignored most of the times, because I am in a domain but work almost 100% time remotely without access to the AD. gpupdate /force then just fails. – Frédéric Oct 24 at 11:19
  • @Frédéric I didn't try recently (not on Win much these days), but this worked for a solo desktop machine setup, nothing else. Pro version though. Surely YMMV, Microsoft is very good indeed at making things 'complicated'. – NSGaga Oct 24 at 13:50
13

I was going through the same issue and here is what I believe to be the most correct answer:

  1. You cannot turn off autocorrect in Windows 10 mail. It lives its own life independant of Windows 10's "typing" settings.
  2. You can, however, change the language for an ENTIRE mail, but it's not obvious how to do that - You might think selecting all and then choosing a language up in the language area at the top of the screen might allow you to type an email in ONE language, but you would be wrong for thinking that so stop it. (it's too logical for today's modern app design, you know)

language setting

  1. Windows 10 Mail listens to the language you set in your system region settings! In order to type an entire mail in a single language, select your language down in Windows 10's language bar before typing. After every character, Windows 10 will poll the language set in the language bar and set it's own language back to that language. That's why setting a language in Mail itself isn't "sticky."

enter image description here

  • 1
    Your answer does work if used, but technically, it's a workaround, and I already mentioned it in the question; I already have several languages installed, and the point was not to install English to be able to write in English. So unless there isn't a possibility to really shut that autocorrect down, a real solution won't exist. – cirko Feb 13 '16 at 20:02
  • You mentioned "English Keyboard" installed. I didn't need that either. I have 2 languages (Swedish, English) both with Swedish keyboard. I agree with you that it's really stupid to not be able to turn off autocorrect, but I think I answered your question "How to turn off autocorrect" with the answer "you can't turn off autocorrect." It's a crappy answer but I think it's correct. You need to install English language with German keyboard - it's the only way. – c.fogelklou Feb 15 '16 at 12:51
  • we'll just take that as the best answer at the moment and hope for Microsoft to come up with something in the near future... (picture a skeleton typing in front of a screen) – cirko Jan 31 '17 at 16:40
  • 2
    Oh for Christ's sake this is stupid design, but at least I know now. This might just make me switch to Thunderbird again, which is a shame since I otherwise quite like the Mail app. Thanks for the information I gathered reading this. – yerforkferchips Apr 1 '17 at 22:15
3

I had the exact same issue so I switched to Thunderbird instead. But still many other apps used the spell checking and auto correct "feature" of Win 10 although it was turned off. But finally I found an easy and definite way to really turn it off in all apps:

1) go to C:\Windows\System32

2) rename MsSpellCheckingHost.exe to MsSpellCheckingHostOLD.exe (or any other name)

3) rename MsSpellCheckingFacility.dll to MsSpellCheckingFacilityOLD.dll (or any other name)

4) restart your PC

Works fine for me. No more spell checking, no more auto-correction. Please could somebody confirm this for the Mail-App as well since I completely removed the Mail and Calendar app from Windows.

Edit: in order to rename the files in system32 folder you have to gain ownership of the files:

rightclick - properties-> security-> advanced-> owner

now set permissions to read and write.

1

Since there is no way to work "against the spell correction" another way is to play along: Mail checks your spelling based on your current language setting. Just add you language in Windows' "Region & Language" setting (don't download language pack! See below). Whenever you want to switch the language you write your mail in, press windows-space to change the language. The text you write in this setting is somehow marked with the corresponding language and gets the right spelling corrections/red underline

Update: Caution: After installing Language Packs Windows 10 (with Creators Update) started behaving strangely, e.g. starting to display Windows in German even though I put English as standard language. I advice to not install the language pack but only the languages itself.

0

I think I found a way.

It's a bit dirty and might lead to unintended consequences, and I haven't actually checked it on the Mail app, which I don't use, but it now works on other apps I'm using that showed the exact same, annoying behavior before.

Do it at your own risk, and make sure to back up your stuff before.

Regedit. Seach for: "AutoCorrection"

You'll find that many entries are still set to "1", and all are in "input/settings/is_..". Change all of these to "0".

I considered automating it, but manually doing it didn't actually take long, it was maybe 30ish entries.

My guess is, they allow apps to control autocorrection behavior on their own and app developers don't utilize the feature, meaning you're stuck in whatever the default is (probably "1").

  • this solution did not work for me, the autocorrection still came up.. – hansaplast May 10 '17 at 7:48
  • @hansaplast have you tried after a reboot? some reg changes need a reboot... – Ben May 10 '17 at 12:06
  • @ben yes I rebooted, but it still did not work – hansaplast May 11 '17 at 7:40
  • Didn't work for me either, several apps are still enforcing autocorrect. – Nicolas Goy Jun 19 '17 at 16:00
0

The following answer in another question helped me tonight after a long fight of OneNote for Windows 10 auto correcting my English words to my local language. Clue is to have your local keyboard inside the English language setting, https://superuser.com/a/1115437/625943

It won't turn off auto correct, but gives you at least control over what language it corrects to, not tied to your keyboard layout.

From post: Go to settings > Region & Language. In "Languages" > Add a language. Add the language that you want to use for language proofing. Click on that new added language and hit "options". Add the keyboard layout that you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.