0

I've been having problems with a blue-screening Laptop (BCCode 124), and I've been trying to track down whats causing it. (It bluescreened randomly after 5-30 minutes of running in win7). It worked in safe mode. I tried reinstalling Windows, which didn't work, so I tried to install various Linux systems which also didn't work.

The only thing working right now is the parted magic version of the ultimate boot cd.(Its a repair linux distro that runs live from ram)

I had the idea to run a bunch of stability tests to try and isolate the faulty component(s), and I wanted some input on my results.

I did different cpu stresstests for different times. No problem (temerature ~60°C sometimes peaks at 65)

I ran memtest with no errors many times.

I also did a GPU check wich is included in the ultimate boot cd - parted magic distro - no problem.

I also checked the hard drive with different tools included in parted magic - no problem there too.

Every linux system I try to install crashes when I try to install it. (It either freezes with no error (rarely happens) or I get something like this shortly after I tell it to install (tried about 20 different distros): [*] 3 photos in the dropbox

Trying to isntall windows 7 just gives a generic "there was a problem" / "an error has occured" screen with no further information.

The laptop is a Lenovo B570. Here are the detailed system specs (the ram is a 4GB kingston now) [*] the hardinfo file in the dropbox

I have 3 crashdumps from Windows wich I can not open. (visual studio says it cant open old crashdump files) [*] 3 dumps in the dropbox

Can you help me to track down the cause?

Edit: im not allowed to post more than 2 links here so here the dropboxfolder with all the things I mentioned:

[*] https://www.dropbox.com/sh/f5v1tojm72js4nm/AADmKa0ahEi036ynHBXJUtDQa?dl=0

  • 1
    What exactly is "secure mode" in this context? – Ramhound Jan 12 '16 at 13:35
  • Have you tried resetting your BIOS settings to defaults? Also, you might want to do some other routine checks like running a memory checking tool (e.g. memtest) and verifying that the CPU fan is working. – James P Jan 12 '16 at 13:50
  • What motherboard do you have? – Moab Jan 12 '16 at 13:55
  • 1
    @t0b4cc0 It appears you have created multiple accounts. I suggest strongly you merge them. Otherwise you won't be able to respond to comments, and end up, submitting an answer erroneously which will be deleted. – Ramhound Jan 12 '16 at 14:31
1

You get a GCACHEL2_EVICT_ERR error (level-2 cache error during a cache eviction event).

0: kd> !errrec fffffa800966a038
===============================================================================
Common Platform Error Record @ fffffa800966a038
-------------------------------------------------------------------------------
Record Id     : 01d0f21d97143e24
Severity      : Fatal (1)
Length        : 873
Creator       : Microsoft
Notify Type   : Machine Check Exception
Timestamp     : 9/18/2015 14:25:03 (UTC)
Flags         : 0x00000000

===============================================================================
Section 0     : Memory
-------------------------------------------------------------------------------
Descriptor    @ fffffa800966a0b8
Section       @ fffffa800966a190
Offset        : 344
Length        : 73
Flags         : 0x00000001 Primary
Severity      : Fatal

Physical Addr.: 0x000000023c175dc0

===============================================================================
Section 1     : Processor Generic
-------------------------------------------------------------------------------
Descriptor    @ fffffa800966a100
Section       @ fffffa800966a1d9
Offset        : 417
Length        : 192
Flags         : 0x00000000
Severity      : Fatal

Proc. Type    : x86/x64
Instr. Set    : x64
Error Type    : Cache error
Operation     : Generic
Flags         : 0x00
Level         : 2
CPU Version   : 0x00000000000206a7
Processor ID  : 0x0000000000000000

===============================================================================
Section 2     : x86/x64 MCA
-------------------------------------------------------------------------------
Descriptor    @ fffffa800966a148
Section       @ fffffa800966a299
Offset        : 609
Length        : 264
Flags         : 0x00000000
Severity      : Fatal

Error         : GCACHEL2_EVICT_ERR (Proc 0 Bank 5)
  Status      : 0xfe2000000001117a
  Address     : 0x000000023c175dc0
  Misc.       : 0x000000372e004086

Look for a BIOS update, if this doesn't fix it, your L2 Cache is damaged and you have to replace the CPU.

  • Wow. Awesome (upvoted) answer by magicandre1981. @t0b4cc0 , can your data please be public domain? I'm an educator, and I think this answer is a superb example of how dump files can be useful. I would like to be able to re-share those data files. (My interest is in educational purposes.) I know that data distributed on Stack Exchange tends to be shareable thanks to the license specified by Stack Exchange, but since the data was technically distributed by Dropbox, I wasn't sure what license this data fell under. – TOOGAM Jan 13 '16 at 18:34
  • ty magic andre! @TOOGAM I study computerscience. Would be happy to see my own post as example! Just download it from dropbox and remove personal things I might have overlooked (ip adress, or real names from the system info idk) – t0b4cc0 Jan 13 '16 at 20:40
1

From Microsoft (emphasis mine):

The WHEA_UNCORRECTABLE_ERROR bug check has a value of 0x00000124. This bug check indicates that a fatal hardware error has occurred.

This, in combination with the fact that you can't run or install most other OSs you're attempting, tells me you definitely have a hardware error of some kind.

The odds of it being a "CPU error" are slim, as CPUs are one of the least likely components to malfunction; More likely a motherboard problem causing the CPU-related errors - but it's basically impossible to say for sure without replacing and testing components.

Regardless of where you start, you should begin troubleshooting the hardware, one component at a time. e.g.: Drives, RAM, PSU, motherboard, CPU, in (basically) that order.

  • no, no Drive or RAM, the L2 Cache of the CPU – magicandre1981 Jan 14 '16 at 5:30
0

I just came here to say that ive managed to get linux running with the startparameter maxcores=1 (its a 2 core cpu).

Thanks for help everyone, you saved me 200 bucks!

So if someone has this error and doesnt feel like repairing hardware/buying new, get linux on it. Install with that parameter and add this parameter to the grub default parameters.

It would be interesting to test the cpu with L2 cache disabled (and with the other core enabled again) but thats a whole different level.

  • this is an ugly workaround and now you only use 1 CPU core and your system is slow to use. – magicandre1981 Jan 18 '16 at 5:08
  • @magicandre1981 yes its ugly. but we cant afford a new laptop, and its only being used to browse the web, watch movies and store photos. 1 core is fast enough for all of this. I didnt claim I repaired it, I just said I got something running wich is enough for now. If you have a better idea I will try. At some point in time i will buy that cpu from ebay when I see a low offer and try that. – t0b4cc0 Jan 18 '16 at 16:35
  • I wonder if any other of the hundreds of startingparams that linux has could serve me better than disabling a whole core. I browsed them yesterday but honestly I dont know much about this stuff and my gf is superhappy that her laptop works again. – t0b4cc0 Jan 18 '16 at 16:42
0

The best way to determine the cause of the blue screen is to analyze the .dmp file using WinDbg. The clearest steps I have seen are in Stu Mackellar's answer on stackoverflow.

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill May 4 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.