1

I'm using Debian Jessie, LibreOffice is 4.3.3.2. I'm having a document for which the text language is 'German (Austria)', alternatively I tried 'German (Germany)'. I can't spell check my text. If I select 'Tools > Spelling and Grammar...' a 'Spelling' dialog pops up with another stupid modal dialog on top that reads

LibreOffice 4.3.3.2
Continue checking at beginning of document?

enter image description here

followed (no matter what I click) by

The spellcheck is complete

Although the text obviously contains mistakes. The text language combo box of the underlying inactive dialog is empty, and also there are no wavy lines in the text as I type.

I already tried apt-get install libreoffice-l10n-de, and also I went through this process of manually downloading some .oxt package from the website and adding it with the extension manager.

Simply, I don't get any German spell checking whatsoever.

1

Looking again at the last output from apt-get, I figured I need to also install these two packages:

  • hunspell-de-de
  • myspell-de-de

Then choosing German (Germany) for the whole text makes it work. (I guess for Austria I could also install de-at).

In the character format language setting, 'ABC' icons appear now next to the supported languages.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.