Using my Microsoft account, I simply cannot log in to Windows 10 via remote desktop. I have tried a plethora of variations, including:

MicrosoftAccount\[email protected]
ComputerName\[email protected]
[email protected]
Etc. etc. etc.

I am confident that I have logged in one time before but I can't seem to find where I saved the username/domain combination I used. I am also confident it is not a setting or the firewall. I have even created a local user account and was able to login successfully with that account.

There must be somewhere that I can lookup the correct username to use.

Judging by so many others having no problems, I suspect this has something to do with either my Windows settings or my account. I am 100% certain that my account has the required permissions to login via remote desktop.

  • How about just UserName?
    – user364455
    Jan 14, 2016 at 12:30
  • I've tried that, too. I've also tried using an old email address with all the domain variations. And I've tried using local and localaccount as the domain. Jan 14, 2016 at 12:31
  • I just check and it works with plain UserName for me.
    – user364455
    Jan 14, 2016 at 13:50
  • I would try using the previous password for RDP if logging in with your MS account. i.e. I am still using the PW that was in use 5x ago when W10 OE was originally built and my MS account was associated with that local profile. Something isn't syncing.
    – SuperSnake
    Jun 13, 2017 at 22:25
  • Have answered this in post below, please check.. superuser.com/a/1423901/1019894 Apr 11, 2019 at 23:22

9 Answers 9


If your Windows account is linked to a Microsoft Account, and you have never logged in by using the current password, then the password will not be cached, and therefore, it's not possible to log in remotely using the password.

This can easily happen if you used one of the passwordless authentication methods to first log into your PC, for example, signing in with a security key or via approval using the Microsoft Authenticator app on your phone, and then continued to use the same method or a PIN for login, or if you changed your password and Windows hasn't seen the new password yet.

The fix in that case is simple. Lock the computer, select the "password" login method, and log in at least once with the current password while connected to the internet - once Windows has seen you log in successfully with the password, it will update the hash it stores locally, and Remote Desktop logins should now work using the Microsoft Account email and password.

There's no need to switch the account to a local account and back, or even to fully log out, only to log in or unlock the computer locally at least once while Windows is able to verify the password against the Microsoft servers.

  • 5
    This was the solution for me. Apr 6, 2021 at 20:01
  • 2
    Thank you, this was also the answer I needed! Nothing at all was working, until I signed out and signed back in with my password instead of my PIN. Now everything is as it should be!
    – KWottrich
    May 21, 2021 at 19:17
  • 2
    This also worked for me. I'll also add that I didn't have the ability to sign in with a password until I disabled the requirement for using Windows Hello. After logging in with a password RDP worked, even after re-enabling the Windows Hello requirement.
    – Chris Romp
    Jun 12, 2021 at 4:40
  • 1
    you saved my day!
    – Marco
    Jun 20, 2021 at 13:52
  • 1
    For me, I enabled passwordless on my Windows 11, so I have to turn it off based on pureinfotech.com/remove-pin-grayed-out-windows-11, after that, I succeed following Stephanie's answer. Oct 19, 2022 at 23:53

I finally figured this out. My Microsoft account and local account passwords were not in sync. I changed the Microsoft account password from within Windows, and BAM, it works again.


Working [email protected] for me without any issues

To check whether your user has access to RDP 1. Control Panel > System > Remote Settings > Remote Desktop 2. Click Select Users and make sure your [email protected] is added there, if not then click add and add it manually

  • I did the same but still doesn’t work, Is Authenticator enabled for your account? Mar 26, 2021 at 19:14

In my case switch into local account I were able to connect successfully and after that reswitching back to Microsoft account the issue was solved.


I use our business Office365 account to log into my computer locally in the Windows 10 environment. I also set up AzureAD when I initially set up Windows 10 which I believe is becoming more standardized after the Win10 anniversary update. Because of this I had to use this credential format to get remote desktop to work:

Username: AzureAD/LocalComputerUserName

Password: (password for your Office365 account)

To figure out what your LocalComputerUserName is just head to Control Panel -> User Accounts -> User Accounts -> Manage Accounts.


I had been having an issue with this for several hours before getting it to work. I was able to use RDP fine before advancing to the fast track of windows 10 insider updates. After updating to the latest build, 16299.15, I was unable to connect with the windows logon credentials I using before, *****@gmail.com and my Microsoft account password.

Initially, I changed my password on the machine I was attempting to RDP into. This did not fix the issue. Next, I used the local username associate with the Microsoft account on the remote machine with the new password I created on the remote machine and it worked.

So ultimately, the login information that worked was User Name: {local username of Microsoft account on remote computer} and Password: {most recent Microsoft account password.}

  • this worked for me.
    – Vijay
    Apr 20, 2020 at 5:54

I was logged in with my Microsoft account and wasn't able to connect with my Microsoft Account or anything else over RDP. I switched to a local account without any password and then logged in again with my Microsoft account. So basically just logged out and in again. Then it worked with my Microsoft account's email as username and my Microsoft account's password.


you can get the domain and user name from the settings->accounts->"sign in with a local account instead". When you click the "next" button, the page will show you your Microsoft account and domain. For example MicrosoftAccount\[email protected]


what worked for me and I am not sure step one is required but that is what I did.

  1. changed the Microsoft account password from within Windows, and BAM, it works again (from: Jason Clement - question and answer above) this did not work on its own and may not be required
  2. I then read the comments and ran the following runas /u:MicrosoftAccount\[my account] cmd.exe (from: angularsen)

after logout and login RDP was working fine for me

Error was shown to me as follows in event viewer of target pc can find in event viewer -> windows logs -> security enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .