6

I am sure I am missing something here. My Chrome runs under a Non Admin a/c so I can't install any extensions . I have an admin rights a/c and tried to run it using alternate credentials

        C:\Windows\system32>C:\Windows\System32\runas.exe
  /savecred /user:IBMClunker\ladmin
 "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"

Chrome pulls up but wont do a think Just get a black slate background and nothing happens. Wont browse any place. So I copied everything the appdata/local/chrome/user data folder to the corresponding folder for Ladmin Still no luck. Has any one had luck getting this to work Am on W7.

1
  • Why don't you just as an Administrator add the extensions, then run Chrome, as the normal user. You should not run Chrome as an Administrator for many reasons including for security reasons. If your running Chrome as an Administrator as another user you might as well just be logged into the Administrator account itself.
    – Ramhound
    Jan 14, 2016 at 17:19

2 Answers 2

5

Add the --no-sandbox switch to Chrome

runas /user:test /profile "C:\Program Files (x86)\Google\Chrome\A pplication\chrome.exe --no-sandbox"

! This will defeat the purpose of running Chrome with restricted account

You can also try to install Chrome for All users at install time.. install Chrome for the specific account you want to use first...

1
  • Works fine, in spite of You are using an unsupported command-line flag: --no-sandbox warning. Thanks.
    – Alexei
    Dec 28, 2016 at 13:26
4

When using Windows 10 (and I think 7) you can hold down shift and right-click the application and choose "Run as different user" ... much simpler.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.