2

I want to filter my emails using the header X-Comment, which appears in some of my messages. I added a filter to do this (using the "Customize" option) and tried to run it on my inbox, but nothing happened.

After some reading online I found this comment on a bug report regarding this issue, so I repaired the folder (right click, "Properties", "Repair Folder") and tried again. Still no results.

When searching for the header using the advanced search, I also get no results.

I also tried this with some other headers like Precedence or MIME-Version just to be sure and got the same results.

Does anybody have an idea how to fix this?

3

I have had this same issue too and reached your question. To me, what "fixed" it was a thunderbird restart.

If I tried to 'run now' the filter, it didn't work at all. Then I closed thunderbird and all its child windows, checked whether there were no thunderbird process (using process explorer), then restarted it.

The different thing (that I think should not be related) was, instead of opening the filters and clicking "run now", I did the following: 1. clicked the folder (Inbox) for which I created the account, (Inbox from the account of course) 2. Clicked the menu button 3. Chosen "Message Filters" menu 4. Chosen "Run Filters on Folder" menu item.

As I had 33,000 mails on that folder, it then hung Thunderbird for a while and voila, the mails which matched that header all moved to the target folder.

1
  • I, too, had to restart Thunderbird after making a custom header filter to make it work. – David Spector Dec 23 '20 at 12:16
1

Well, the problem just went away. Even though restarting Thunderbird did not help, the filter works just fine today (after rebooting Windows, so that may have helped).

I noticed that a new email was correctly recognized by the filter which prompted me to have a closer look again. I had to repair the folder another time, but now it works like a charm.

Who knows what changed..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.