3

On occasion when I am not physically at home, I will login remotely to my computer using Remote Desktop. When I return home I then have to login locally; however, immediately after login I am presented with a black screen. Has anyone else encountered this issue and know of a solution?

Additional Information

As far as I can tell the system appears to switch over to virtual devices for the remote desktop session, but when I then login locally it doesn't switch back to the physical devices.

I don't have any trouble with local logins normally. And I can login remotely repeatedly without issue. It's only when I attempt to login locally after I have been logged in remotely that the issue occurs.

While viewing the black screen, Ctrl-Alt-Del does not appear to do anything. There is a mouse cursor visible that I can move around for a short time (5-10 seconds) before it freezes. Once it reaches this point, the only remedy I have found is to hard restart my computer physically using the power button.

The computer was upgraded from Windows 7 where I used to do the exact same thing and had no trouble at all. I could remote desktop into my computer assuming the existing session, then login locally and assume the same session, and repeat as I wished.

I have uninstalled and reinstalled drivers for my monitor (Samsung SyncMaster T240HD) and display adapter (EVGA NVIDIA GeForce GTX 670). I have logged into safe mode, enabled display all hidden devices, and uninstalled all other monitor or display adapter devices that I could find, which was only a single hidden monitor device for an old monitor I had.

I have checked the system, application, and security logs and found no warnings or errors either during the remote login or the subsequent local login.

2

Issue is related to the nVidia GeForce Experience ShadowPlay feature. When ShadowPlay is turned on (not recording just enabled), then the issue occurs. When ShadowPlay is turned off, then no issue. Whether the issue is ShadowPlay or Remote Desktop I can't say, but the two of them interacting together on Windows 10 caused the black screen of death.

I'm not the only one to notice this problem. The only reason I even played with the setting was because someone else had a similar issue with a different version of the software: https://serverfault.com/questions/724459/black-screen-after-rdp-session

| improve this answer | |
  • This is correct, but as of April 2018 this feature is called "In-game overlay". – dantheman2865 May 3 '18 at 2:16
1

Try checking the display settings and seeing if there is a phantom monitor present. Might need to change which monitor is the primary one. Also try uninstalling the monitor drivers under device manager.

| improve this answer | |
  • Sounds like an issue with the drivers, Josh is correct in recommending to update the video card drivers. The more complicated explanation is that when you use Remote Desktop, a virtual monitor is attached to your machine (this allows for fancy stuff like matching DPI from client, resize of the RD window etc.). When you login locally, the machine has to disconnect the virtual monitor and reset the settings for the local monitor. – cdavid Jan 14 '16 at 18:56
  • Display settings are disabled when connected through remote desktop, and the black screen prevents me from checking after logging in locally. If you mean during a regular login, then I don't see any secondary monitor present. This is a simple single monitor scenario. As for drivers, thanks for the suggestion but I had already gone through that before posting here. I have updated my question to include more of the basic troubleshooting I've already gone through. – Sybeus Jan 15 '16 at 1:17
  • I had what I believe what was a similar issue and was able to resolve by assigning a different monitor as primary. Perhaps try and connect another monitor and change the primary monitor and then change back. – xpkiro Jan 15 '16 at 18:35
  • Took a couple days to get my hands on another monitor, but I did and then did as you suggested. Nothing changed, still the same issue. – Sybeus Jan 18 '16 at 18:47
  • I imagine you've already tried replacing the video cable with a known good one? – xpkiro Jan 19 '16 at 18:33
1

I was able to make this work with following suggestion.

https://superuser.com/a/1459488/1075541

In Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment, set the Policy Use `WDDM graphics display driver for Remote Desktop Connections' from "Not Configured" to "Disabled."

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.