I have Windows 10 built 1511 with all the updates.

After I make a system restart some of the services with startup type Automatic don't start automatically.

But I can start them manually and after that everything is ok. But if I make a system restart, the problem appear again.

If I start the service manually, and after I do shutdown, everything is ok when I turn on again the PC. So the services are automatically started as should be. The problem appear only if I restart Windows. After restart, these services are not started automatically.

This problem appears only to some services that are related with applications (not those that are system services). These services don't depend to any other.

What can I do?

  • Maybe you could give some examples of such services that fail to start. It's hard to guess what the issue may be without any details.
    – dxiv
    Jan 16, 2016 at 0:12
  • 5
    If it makes you feel any better, you are not the only one. I have the exact same issue. The services are 32 bit. Custom software installed quite some time ago. So the WOW64 setting is there, turned on. I can start the services manually, but ever since upgrading from Windows 7 to Windows 10, the OS makes NO attempt to start the services. Their trace files show nothing, and the Event Log shows no attempt to start them, nor any problem with them. It is very frustrating. The Automatic Delayed is a lousy option, but I guess that's it for now...
    – Brian B
    Apr 5, 2016 at 22:26
  • See also here: stackoverflow.com/questions/33238665/…
    – RenniePet
    Nov 25, 2017 at 2:43
  • 1
    For me when having this problem, changing "This account" in "Properties>Log On" for the service, to a network name in the form "MyDomain\MyUser" from "[email protected]", solved the issue, although I have no explanation why.
    – MBWise
    Mar 14, 2018 at 13:07

10 Answers 10


The only solution that works for the moment is to change the startup type of these services from Automatic to Automatic Delayed. I don't know if this is the best solution , but is the only that works for now.

  • If you are comfortable with regedit, I discovered that as long as the service has the key DelayedAutostart (DWORD), it will start. So I added this but set value to 0, as I did not want it delayed. Example: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<yourServiceName>\DelayedAutostart
    – Brian B
    Apr 21, 2016 at 15:26
  • 1
    I also found a thread on Microsoft technet, social.technet.microsoft.com/Forums/windows/en-US/… On that thread the OP says you can also use "restart on failure" as a workaround.
    – RenniePet
    Nov 25, 2017 at 2:39
  • This worked for me in combination with de-selecting "Prefer 32-bit" as mentioned in the answer below by @Michael van der Horst
    – threadster
    Apr 15, 2020 at 15:34

My previous answer did not fix our problem. In the end, we fixed it by setting the time out of the services to a higher value. Try this solution:

Go to Start > Run > and type regedit

Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

With the control folder selected, right click in the pane on the right and select new DWORD Value

Name the new DWORD: ServicesPipeTimeout

Right-click ServicesPipeTimeout, and then click Modify

Click Decimal, type '180000', and then click OK

Restart the computer


The Microsoft Windows Service Control Manager controls the state (i.e., started, stopped, paused, etc.) of all installed Windows services. By default, the Service Control Manager will wait 30,000 milliseconds (30 seconds) for a service to respond. However, certain configurations, technical restrictions, or performance issues may result in the service taking longer than 30 seconds to start and report ready to the Service Control Manager.

By editing or creating the ServicesPipeTimeout DWORD value, the Service Control Manager timeout period can be overridden, thereby giving the service more time to start up and report ready to the Service.

Reference case:

Reporting Server Error 1053: The service did not respond to the start or control request in a timely fashion


Good luck This is the source of the fix


You can modify the startup from "Automatic triggered" to "Automatic" by command: sc triggerinfo w32time delete

Now, the service can start automatically after reboot

  • Trying to understand: is this new idiotic "feature" of Windows, or it existed long ago? Turned out my business-critical servers were not synching with ntp server 'cause Windows Time service has suddenly changed its start type from Automatic to Automatic (Trigger start) and of course any attempt of a scheduled task to synchronize time was failing. Dec 23, 2018 at 3:50

What fixed it for us is, if you can change the service executable yourself:

In the project file change the Prefer 32-bit flag to false, then reinstall the service.

Check your service with CorFlags.exe. The 32BITREQ and 32BITPREF should be 0.

Version   : v4.0.30319
CLR Header: 2.5
PE        : PE32
CorFlags  : 0x1
ILONLY    : 1
32BITREQ  : 0
Signed    : 0
  • Do you know of a way to set the preference flag in Visual Studio 2010? Mar 18, 2018 at 21:55
  • No I don't, but you can check your csproj file, it should then contain the <Prefer32Bit>false</Prefer32Bit> in your propertygroup of Release. Mar 28, 2018 at 12:51

Well, Windows can stop these services if they are not needed or if there is an instruction to stop the service after whatever it is doing. Some services depends on other services and they will only start when the first calls them.

An error can cause the service to stop prematurely too. You could go to the Event Logger and see if there are errors related to these services. If there is a "(Triggered start)" after it, these services usually are not required or they only start when it is needed to, for example, Biometric services.

You can also find further information about how services works here.

Unless you are noticing your PC is not working properly, it really shouldn't be a problem.

  • 3
    Sorry friend , but maybe you have not understand what I'm saying. These services have Automatic Startup type , and are not System services. They are installed after some application's installation. Are working very well. If I shutdown windows , and turn on , these services start automatically and everything works ok. But the problem appear if I restart windows. After restart these services does not start automatically , and application related to them doesn't work. I can start manually and everything works fine until I do another restart and the problem appear again.
    – alex
    Jan 15, 2016 at 1:01
  • Hmm, I guess you should really take a look at the Event Logger to see if the services generates some kind of error. So you can open it and look for messages near the timeframe you restarted your PC. If they are stopping prematurely because of an error, the description or code of that error might be found there and we can have a better idea of what the real problem is.
    – axys93
    Jan 15, 2016 at 1:58
  • 1
    No , no error at Event Logger. There's no log that describe a premature stop. The service just doesn't start. It seems that if I restart windows 10 , the system just ignore the Automatic Startup type of these Services.
    – alex
    Jan 15, 2016 at 2:39
  • 1
    @alex Your link references a discussion thread on technet, where it is noted that there is an entry in the event log indicating that the service failed to start ("The SQL Server (MSSQLSERVER) service failed to start ..".). That's quite different from your claim The service doesn't fail to start. At the risk of repeating, your question is unanswerable as-is now, without any details.
    – dxiv
    Jan 16, 2016 at 2:07
  • 1
    @alex It's not my link. Did you even read the link you posted? The 2nd paragraph says The issue is reported on below MSDN thread https://social.technet.microsoft.com/Forums/sqlserver/en-US/bb5f2199-f283-4249-a029-53978d637148/sql-service-stops-working-after-windows-10-upgrade?forum=sqldatabaseengine which is precisely where I quoted from. Anyway, at this point I'll leave it to others to second-guess what the problem might be without any assistance from your part.
    – dxiv
    Jan 16, 2016 at 3:05

I had the same problem. The services did not restart automatically after the machine was restarted. The reason is that the Windows 10 shutdown button does not mean (unlike Windows 7) a shutdown but can be considered as a standby if the "Set Power Buttons" configuration is as this.

In this case, if the services were stopped, they remain so. If they were started, they continue to run without being restarted (no initialization). Jean-Marie

  • 1
    How do you conclude this? Can you provide any source? Jan 11, 2017 at 8:56

Try with the below command:

sc config "SVCNAME" start= delayed-auto

If someone still have issue about it : NSClient version 0.5 removed trigger detection from default service state. We have to add it manually :

*your_command* check_service -a "filter=is_trigger=0" *other_arguments* 
  • What should be in place of "your_command'? Aug 11, 2021 at 12:14

See the comment from MBWise:

For me when having this problem, changing "This account" in "Properties>Log On" for the service, to a network name in the form "MyDomain\MyUser" from "[email protected]", solved the issue, although I have no explanation why. – MBWise Mar 14 '18 at 13:07


Try with this:

Run the following command to define a trigger event that suits your environment. In this example, the command determines whether an IP address is given to a host, and then it starts or stops the service.

sc triggerinfo w32time start/networkon stop/networkoff

where w32Time is your service name

or try this


  • Please read the question again carefully. Your answer does not answer the original question.
    – DavidPostill
    Oct 6, 2016 at 9:19
  • running into something similar delayed start is also not as effective it is an improvement, trigger info helps.
    – amritanshu
    Feb 18, 2019 at 8:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .