2

Every time I try and install a Windows 10 update, it fails with this message (at 91% completed on the second stage of the update).

Graphics cards: Intel HD Graphics 4600 (driver version 20.19.15.4300 Intel)
NVidia Geforce GTX 765M (driver version: 10.18.13.6143 NVidia)

Checking event log also shows that ReadyBoot crashed, error: 0xC0000188

I increased the size of the log, and will update when I try again.

How can I solve this problem? I am currently stuck on Build 10586.

Update 1: Updated drivers to latest versions. No change, still failed with the same blue screen during update.

Update 2: Result of sfc /scannow. In the past I have been able to fix this with dism and a windows image. I have not done that again. The fixes seem to be temporary

Update 3: Restarted, and it failed, without a minidump. Links to event logs from that time: link1, link2. I believe the volume error for the crash dump initialization failed for my C: drive. Below is my disk layout:

enter image description here

Update 4: Disabling the nvida card, running dism, restarting, and then sfc passes. Update still fails with the same error. I was unable to uninstall both drivers. The intel one (and sometimes even the nvidia one) comes back, even after selecting the delete driver options.

Update 5: Contents of windows update log

  • Neither of those drivers are up to date, might be worth trying that first? – Jonno Jan 15 '16 at 9:47
  • @Jonno trying that now. I figured that stock drivers would always work – soandos Jan 15 '16 at 9:49
  • @Jonno, done, and no change – soandos Jan 15 '16 at 11:07
  • Just to confirm, what update are you trying to install? You say you're stuck on Build 10586, but that's the latest build AFAIK? – Jonno Jan 15 '16 at 11:20
  • @Jonno windows update is trying to give me 11099 – soandos Jan 15 '16 at 11:21
4
+150

That has nothing to do with your video card driver. Try increasing the size of the ReadyBoot.etl. Here is how to do it:

  1. Search, Performance Monitor
  2. On your left side, expand Data Collection sets
  3. Click on Startup event traces
  4. On your right side you'll find a list, double click Readyboot
  5. Click on the Stop Condition tab and set the size you want. A good size would be 128MB. It defaults to 20MB.
  6. press OK. Close everything, reboot
  7. See if the error goes away.
  • Why do you believe this exactly? What does increasing do exactly? – Ramhound Jan 31 '16 at 5:49
  • Since I suspected you were correct about the solution, I went ahead and did my own research, and then submitted my own answer to this question. I provided you credit where it was possible solution, the best I could, but simply telling how to increase the size of the file really isn't enough its important to know the reason you are increasing it in the first place. Since I determine the instructions were not 100% original the quote provide is actually from the Microsoft Answer thread and not your answer itself. – Ramhound Jan 31 '16 at 6:21
  • Nothing. See update – soandos Feb 2 '16 at 4:21
2

I suspect Ken is actually right in his suggestion to increase the size of the ReadyBoot file. If the following event was logged:

"The maximum file size for session "ReadyBoot" has been reached. As a result, events might be lost (not logged) to file "C:\Windows\Prefetch\ReadyBoot\ReadyBoot.etl". The maximum files size is currently set to 20971520 bytes."

It does indeed mean that you have to increase the size of the ReadyBoot.etl file. It is worth pointing out that:

Windows 7 set the ReadyBoot.etl file to 20MB and in the event logger this size often is maxed during boot (aka not enough), increasing it can really help.

If the event above was indeed logged then you should increase the allowed size of the file being generated. You can do that by doing the following:

  1. Search, Performance Monitor

  2. on your left side, expand DATA COLLECTORS SETS

  3. Click on STARTUP EVENT TRACES

  4. on your right side you'll find a list, double click READYBOOT

  5. click on the STOP CONDITION tab and set the size you want

  6. Select the File tab

  7. Click the checkmark box next to Circular [requires a non-zero maximum file size

  8. press OK , close everything, reboot

enter image description here

You can tell the solution worked because the ReadBoot.etl within C:\Windows\Prefetch\ReadyBoot will be larger then the default 20 MB, which would be the case, if you had originally upgraded from Windows 7. I can also confirm that an upgrade, from Windows 8.1, would result it being set to 20 MB by default also.

Here is a description of ReadyBoot:

On systems with more than 700MB of RAM, ReadyBoot uses data from 5 previous boots to create a plan for a boot-time memory cache. Similar to Windows XP prefetcher, it will try to preload files into RAM before they are needed. All memory used by ReadyBoot is automatically released 90 seconds after booting up, or immediately if another service needs it, so it doesn't have negative performance consequences.

In other words, on an SSD system, ReadyBoot may not improve boot times by a lot, but it will utilize your fast RAM for what it's good for: serving as a fast cache for the disk. And even the fastest SDDs are still slower than RAM memory - disabling it would still make your booting slightly slower.

Which comes from this answer by Groo to this question

You can determine if ReadyBoot is even enable by looking at this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\Autologger\ReadyBoot

If you want it enabled set the value is 1 if you want it disabled set it to 0

Here is the full Microsoft description of ReadyBoot:

Windows Vista uses the same boot-time prefetching as Windows XP did if the system has less than 512MB of memory, but if the system has 700MB or more of RAM, it uses an in-RAM cache to optimize the boot process. The size of the cache depends on the total RAM available, but is large enough to create a reasonable cache and yet allow the system the memory it needs to boot smoothly. After every boot, the ReadyBoost service (the same service that implements the ReadyBoost feature just described) uses idle CPU time to calculate a boot-time caching plan for the next boot. It analyzes file trace information from the five previous boots and identifies which files were accessed and where they are located on disk.

It stores the processed traces in %SystemRoot%\Prefetch\Readyboot as .fx files and saves the caching plan under HKLM\System\CurrentControlSet\Services\Ecache\Parameters in REG_BINARY values named for internal disk volumes they refer to. The cache is implemented by the same device driver that implements ReadyBoost caching (Ecache.sys), but the cache's population is guided by the ReadyBoost service as the system boots. While the boot cache is compressed like the ReadyBoost cache, another difference between ReadyBoost and ReadyBoot cache management is that while in ReadyBoot mode, other than the ReadyBoost service's updates, the cache doesn't change to reflect data that's read or written during the boot. The ReadyBoost service deletes the cache 90 seconds after the start of the boot, or if other memory demands warrant it, and records the cache's statistics in HKLM\System\CurrentControlSet\Services\Ecache\Parameters\ReadyBootStats, as shown in Figure 2. Microsoft performance tests show that ReadyBoot provides performance improvements of about 20 percent over the legacy Windows XP prefetcher.

This pretty much sums it up:

Since all file activities done at boot time (even system updates and spyware scans) accumulates in this file, it may fill with obsolete information. The fix is to set the ReadyBoot.etl into Circular logging mode, so that only the most recent file access activity is tracked.

Sources Used

Primary Source - Diagnostic Information, Event Information, Instructions.

Background Source - Primary source's own citation to the solution they describe in the Microsoft Answer thread.

  • No dice. See update – soandos Feb 2 '16 at 4:21
  • I am confused. The bounty was awarded by the Community but the full amount was awarded, normal this would have been only half, from my understanding of bounties. – Ramhound Feb 11 '16 at 21:12
  • @soandos - I find it hard to believe you are still getting 0xC0000188 errors. The update might still be failing, but it certainly is failing, for a different reason. You indicated you would "update" the question you never did that. – Ramhound Feb 11 '16 at 21:16
  • I was still getting those errors, and I did update the question (many times after feb 1). I ended up giving up and doing a full reset from a fresh image, and have not yet gotten a prompt to update. – soandos Feb 11 '16 at 21:24
0

There are several things you can try.

Fiddle with the driver

I don't know how you "uninstalled" the graphics drivers, but I have heard that it's necessary to remove NVIDIA drivers through Programs and Features rather than just Device Manager.

There was a relevant NVIDIA driver update published just a couple weeks ago, on January 27. If you haven't done so already, try installing it - Windows doesn't always get the newest versions of all drivers through Windows Update. According to its release notes (PDF), it does fix some blue-screen errors. I would suggest making a System Restore point first.

You might also run the Display Driver Uninstaller, which does a thorough removal of NVIDIA and Intel drivers. Danger! This tool is not endorsed by NVIDIA, and I have not tried it myself, but I have heard several stories of it working well.

You can also try disabling - not deleting/uninstalling - the NVIDIA card in Device Manager. That way, the OS will not attempt to reinstall or reconfigure it when the system comes back up. Again, making a restore point is advisable.

Enabling Driver Verifier sounds promising as well if you've tried all of the above without success. If the system BSOD's under verification, the resulting minidumps may include more useful information for troubleshooting.

Fiddle with Windows Update

I wouldn't be surprised if you've already done this, but if you haven't, it's worth a shot. Download and run the Windows Update troubleshooter for Windows 10. (It might not fix this crash, but I did notice some other update installation failures in your event logs.)

Some of the Windows Update errors in the event log included an error code that usually means that you need to redownload the installation media. According to this answer, you need to stop the Windows Update service, clear out the C:\Windows\SoftwareDistribution\Download folder, and restart that service. If that doesn't work, rename or remove the whole SoftwareDistribution folder.

Fiddle with the Registry

The WIM-mounting part of the upgrade process can run into trouble in one of two common scenarios:

  1. HKLM\SOFTWARE\Microsoft\Windows\WIMMount\Mounted Images contains subkeys or entries of any kind. Clear it out to remove abandoned bookkeeping if you've dealt with WIMs in the past.
  2. The ImagePath entry in HKLM\SYSTEM\CurrentControlSet\Services\WIMMount is incorrect. If it doesn't point to a real copy of wimmount.sys, track down that file and update the path, leaving the preceding \??\.
-1

You could try these steps:

System File Checker is a handy tool included with Windows that allows you scan for and restore corruptions in Windows system files (including those related to VIDEO_DXGKRNL_FATAL_ERROR). To run System File Checker (Windows XP, Vista, 7, 8, and 10): Click the Start button. Type "command" in the search box... DO NOT hit ENTER yet! While holding CTRL-Shift on your keyboard, hit ENTER. You will be prompted with a permission dialog box. Click Yes. A black box will open with a blinking cursor. Type "sfc /scannow" and hit ENTER. System File Checker will begin scanning for Error 0x113 and other system file problems (be patient - the system scan may take a while). Follow the on-screen commands.

Second:

While most storage-related, 0x113 blue screen errors are caused by problems with your hard disk drivers or storage controllers, in some cases these BSODs can be attributed to hard drive corruption. Over time, your PC can develop errors on the hard disk drive due to repeated, unintended misuse. Improper shut downs, “hard closing” programs, corrupt or incomplete installation of software (eg. Windows Operating System), Microsoft Corporation hardware failure, and power outages can corrupt your file system and stored data. As a result, you may experience blue screen errors associated with VIDEO_DXGKRNL_FATAL_ERROR. Microsoft has included a convenient utility called “chkdsk” (“Check Disk”) to scan and repair hard disk corruption. If the previous troubleshooting steps did not resolve your 0x113 STOP error, running “chkdsk” may uncover and repair the cause of your BSOD. How to run “chkdsk” (Windows XP, Vista, 7, 8, and 10): Click the Start button. Type "command" in the search box... DO NOT hit ENTER yet! While holding CTRL-Shift on your keyboard, hit ENTER. You will be prompted with a permission dialog box. Click Yes. A black box will open with a blinking cursor. Type "chkdsk /f" and hit ENTER. "chkdsk" will begin scanning for hard disk corruption that could be causing 0x113 STOP errors. Follow the on-screen commands. Source: http://www.solvusoft.com/en/errors/blue-screen-errors/microsoft-corporation/windows-operating-system/bug-check-0x113-video-dxgkrnl-fatal-error/

Last option would be to remove the appropriate driver causing the issues and reinstall it from the original source.

While also give a try to this steps:

Method 1: I request you to check if the Superfetch service is enabled a. On the desktop, press Windows key + R to open the Run Dialog. b. Type services.msc in the Run Dialog, and then press Enter to open Services. c. Right-click the Superfetch service, and then click Properties. d. If the Startup type box is set to Disabled, change it to Automatic or Manual. e. Click OK to close the Properties window. f. Right-click the Superfetch service, and then click Start. The service should start without errors.

Method 2:

Increase the maximum files size of the Startup Event Trace Sessions.
a. On the desktop, press Windows key + R and type cmd to open the Command Prompt. b. On the left panel of the Performance Monitor window, expand Data Collector Sets. c. Click on Startup Event Trace Sessions. d. Open ReadyBoot Trace Session Property Sheet. e. Click on the Stop Condition tab and increase the Maximum Size to 40. f. Click on Apply and OK. Source: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/circular-kernel-context-logger-error-0xc0000188/d2aa4b79-be60-43d0-8d31-0072235a8f43

  • Quoting indicates your quoting somebody so who are you quoting? – Ramhound Feb 2 '16 at 1:20
  • @Ramhound added sources to this. – Uhl Hosting Feb 2 '16 at 1:51
  • Nothing, see update – soandos Feb 2 '16 at 4:21
  • @soandos have you tried to remove both drivers from Intel, Nvidia, and do this:Run this in terminal dism.exe /image:D:\ /cleanup-image /revertpendingactions Replace D:\ with the correct letter of the drive where Windows is installed (use bcdedit | find /i "OSDEVICE" command to determine the drive letter). Ignore error messages about scratch directory size. – Uhl Hosting Feb 2 '16 at 5:02
  • See updates. I can remove just nvidia, and the rest is done and results are posted. As far as doing dism see update – soandos Feb 2 '16 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.