2

Before my problem, I was able to copy and paste regularly on my local machine and between my local machine and local desktop. For some reason, I am unable to exactly that now. Before I connect to a remote desktop, I am able to copy and paste just fine (with and without keyboard shortcuts). When I connect to a remote desktop using RDP and try to copy and paste from my local machine to the remote desktop or even copy and pasting on my own machine it doesn't work. The option for using clipboard on my "Local devices and resources" is checked. does anyone have an idea?

Edit: Client is Windows 7 Profession SP1 Server: Windows Server 2012 R2 Base RDP Client: Windows Remote Desktop Connection

4
  • Please give some more infos, like: Source/Target OS, RDP-Client/Server-Version
    – Ben
    Jan 15, 2016 at 15:43
  • I made the appropriate changes.
    – LampPost
    Jan 15, 2016 at 15:58
  • 1
    Just a suggestion: Check if rdclip.exe is running on the server (see Taskmanager). If not, you can try to start it manually. Maybe you have to restart the whole server.
    – Ben
    Jan 15, 2016 at 17:36
  • Wow that worked, you're more than welcome to paste that as an answer.
    – LampPost
    Jan 15, 2016 at 18:39

1 Answer 1

7

Just a suggestion: Check if rdpclip.exe is running on the server (see Taskmanager). If not, you can try to start it manually.
Maybe you have to restart the whole server.

4
  • 1
    before restarting the server try to kill rdpclip.exe and start it from command line (it exists in system32 folder). Mar 19, 2018 at 12:09
  • 1
    @AndrzejMartyna if a EXE lives in the System32 folder you can start it from a CommandPrommpt from any directory. This actually applies to any exe in any of the directories in Environment "Path" Variable. Jan 16, 2019 at 23:36
  • that's right, mentioning system32 was, let say, redundant ;) Jan 17, 2019 at 13:07
  • 1
    This worked for me as well, I once had two copies of rdpclip running one of which occupied 80 Mb RAM, that seemed to disable clipboard exchange. Killing both instances and launching a new one fixed the problem. Rebooting the system was more painful (server). Just to add something useful to my answer here's the command to relaunch rdpclip: taskkill /f /im rdpclip.exe & rdpclip
    – Fr0sT
    Dec 16, 2019 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.