0

I was trying to install Kubuntu to an MSI laptop with a UEFI BIOS. It has a Windows 10 already and I'd like to have a dual boot.

I downloaded the Kubuntu 15.10 ISO from their official website and checked the SHA256. After this, I burnt the ISO to a 8GB USB flash disk by unetbootin.

However, after selecting Kubuntu from its GRUB menu, the program just either stuck at the Kubuntu logo without any operations to the USB disk (LED off) or stuck straight after the logo with an unmovable cursor at the center of the black screen, operating the USB disk constantly (LED blinked).

A list of what I've tried is (none of them worked):

  1. Disabling Fast Startup in Windows 10 (I've disabled hibernate)
  2. Disabling Secure Boot in BIOS
  3. Switching Fast Boot on/off in BIOS
  4. Choosing boot mode among UEFI with CSM, LEGACY and UEFI

I'm really confused now. Any help would be greatly appreciated.

UPDATE

I can normally boot Kubuntu 14.04.3 USB disk.

0

I don't think this will fix your problem as your symptoms seem slightly different, but it's worth a try:

check the grub menu. Some distributions have a file called casper/vmlinuz, whilst others have casper/vmlinuz.efi. open the iso (install mc and run mc from command line, point it to the iso and hit enter over the iso, you can then view contents), and see if kubuntu has vmlinuz, or vmlinuz.efi. update your grub menu accordingly. Note this can differ between 32-bit and 64-bit dists, you need to check each one.

Pingers.

0

@Pingers

I found that pressing F11 would show the boot log so that I can do troubleshooting. (I once used Fedora which would directly show it.)

So I noticed that the booting progress was stuck at the line of /init: line 7: can't open /dev/sr0: No medium found.

I googled it and found https://www.kubuntuforums.net/showthread.php?52564-SOLVED-Kubuntu-fails-to-boot-with-USB-stick-but-successfully-boots-with-CD and https://bugs.launchpad.net/ubuntu/+bug/500822 . It seems that although there isn't a floppy setting in my BIOS but it actually features a virtual floppy.

So the solution is adding --ignore-floppies to the boot command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.