-1

In my desktop computer I have 2 drives: 1 SSD (windows) and and 1 hdd (linux). I used to have a mechanical toggle switch to select one of them before booting (did not want to have a boot manager to choose the OS from). Now, I needed more storage and formatted the hdd as ntfs, to use it as data storage for windows. The hdd drive is now completely empty. However, if I start the computer, it won't boot to windows, but says something about "grub rescue". Then I switched the eSATA connectors of the 2 drives and voilá, windows is booting.

  • Why is there a message of grub? I completely removed linux!
  • Why does the order of the eSATA connectors change anything? How reliable is this, I do not trust that booting works once I changed the connectors.
  • How can I make the hdd non-bootable? I can only select "primary" when formatting.
  • You have to replace grub with the Windows Bootloader, since you got rid of Linux, have you done that? – Ramhound Jan 16 '16 at 19:19
  • I had 2 completely different, non-interacting hard drives (toggle switch??). I do not have grub on my windows harddrive. I formatted the linux hdd. Why is this not enough? – user2366975 Jan 16 '16 at 19:27
  • When you installed Linux you pretty much have to replace the Windows loader with grub in order to boot to Linux. I suspect it at least. The fact your getting grub indicates something is going on you don't fully understand. – Ramhound Jan 16 '16 at 19:31
  • When i installed Linux on my 2nd drive, the 1st drive was not plugged in (used a pendrive to install). I wanted to completely avoid this bootloader stuff, this is why I have the physical switch. Seems it still got me. – user2366975 Jan 16 '16 at 19:35
  • In BIOS, what drive are you booting from? Are you sure that you have your SSD selected? It seems that it is just booting from a specific SATA port, ignoring which drive is attached to it. – ethanwu10 Jan 16 '16 at 19:50
1

This has most likely to do with your BIOS settings. You said you formatted the Linux HDD, which would mean there is still the boot partition but it fails to find the OS partition. You should have instead repartition the drive.

So during the boot press the correct key combination to enter your BIOS. (each motherboard has different key combo, look into your user manual). There you will find a boot section and the order of the SATA drives to use for the boot:

enter image description here

Now I have the same setup as you (Windows + Kali Linux) and I simply switch the order of HHD in the bios to booth from the one I want. No software to install, no messing with HW switches or cables.

1

The first bits of a boot loader (GRUB) and a boot signature are stored in the first sector of the disk along with the partition table. This area is called Master Boot Record (MBR). To remove the remnants of GRUB, you will have to erase the first 440 bytes of the MBR.

On Linux, this could be done with the following commands:

ls -l /dev/disk/by-id/
# Recognize your disk from the list!
dd if=/dev/zero of=/dev/disk/by-id/YOUR-DISK bs=440 count=1

On Windows, you can use the diskpart utility. You will need to first read the partition table and save it somewhere (unless you wish to reformat the disk), then use the clean dommand to remove the whole MBR sector, then recreate your partition exactly where it was without formatting it. (If you fail to recreate the partition exactly as it was, your data will be lost.)

Or, you can avoid the error message by switching the disks (as you did) or change BIOS configuration to make the right disk the first choice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.