41

So, I needed the Semantics Engineering with PLT Redex textbook to complete a homework assignment this week. I needed it in a digital format because I'm going to POPL 2016 tomorrow and I can't have it delivered to me. Hence, I paid $50 for the eBook so that I could complete my homework.

The problem is that I'm using Arch Linux and for some reason Adobe Digital Editions doesn't work for me. During installation it said that it might not work on a 64-bit system. Anyway, I tried to find an alternative solution and I learned that I could read the book using Bluefire Reader on my phone.

And it worked. I can read the book, but I don't want to read the book on my little phone screen. So, I transferred the PDF file that Bluefire Reader downloaded to my laptop in hopes that I could open it using a simple PDF reader. Then I double click on the PDF file with a smirk on my face... and it asks me for a password.

I hope you can understand my frustration. All I want to do is read the book that I legally purchased on my laptop so that I can complete my homework and get on with my life. I tried using other eBook readers like Calibre but it requires that I convert my ACSM file to EPUB using Adobe Digital Editions (which doesn't work for me). What other alternatives do I have?

| |
  • You could boot to an android x86 usb and read it there, or install an android vm. – geek1011 Feb 2 '17 at 16:52
  • Another thing which probably would not work, but it is worth a try is archon-runtime.github.io or ARC welder from Google – geek1011 Feb 2 '17 at 16:53
  • 3
    You can't "convert" an ACSM to EPUB - the ACSM ist just a tiny XML file basically containing a download link for the (probably DRM-protected) file. The fine print also states you did not "purchase" the book, but only a license to read it on the specific platforms on which you can use your ADE login. The only way would to download it on a system on which your ADE works, and then maybe to strip the DRM protection. – jvb May 12 '17 at 7:08
  • @jvb That's not true, it can be done, relatively easily, but I don't think we are allowed to show the way here. – Quidam Sep 12 '17 at 8:28
  • 1
    @Quidam: I know it's theoretically possible that a conversion method could be used for illegal purposes, but that's not what this question is asking. I have a similar situation where I have purchased a book that I'd like to remove the encryption on. I, for one, would like to see the "relatively easy" method listed here as one of the answers. – hackerb9 Apr 14 '18 at 2:19
19

The question is quite old, but people like myself still trip up on DRM locked ebooks. I assume you want to get out of the acsm a DRM-free epub. My instruction is for Ubuntu/Debian using apt-get, but the tools exist for other distros as well. I need a couple of tools in particular: the latest DeDRM tool and wine. On wine, we will install Adobe Digital Editions, python and pip for windows

  1. Install wine and winetricks because we will run Adobe Digital Editions in wine. By default ubuntu19.10 intalled wine 4 on my machine. Its easier to upgrade to wine5 first. ADE works so much better with wine5.

     sudo apt-get install winehq-stable winetricks
    
  2. Install dotnet40

     winetricks dotnet40 
    
  3. Now download Adobe Digital Editions for Windows and install it:

     wine Downloads/ADE_4.5_Installer.exe 
    
  4. After installing and launching DigitalEditions you will need to authorize you computer or log in with your adobe id if you don`t have one create it for free.

  5. Open in ADE the acsm file. It will download the epub into your user documents folder (e.g., ~/Documents ) in sub dir "My\ Digital\ Editions". Note that the file is still DRM protected.

  6. Now its time to run DeDRM from python wine. Unzip DeDRM tool and locate the adobekey.py file.

  7. Download VCForPython27.msi, we need it for pycrypto

  8. Install python, pip, vcforpython, and pycyrpt:

     winetricks python27 # this should also install pip
     wine msiexec /i ~/Downloads/VCForPython27.msi
     wine python.exe -m pip install pycrypto
    
  9. Run adobekey.py from the dedrm you downloaded before with wine python:

     wine ~/.wine/drive_c/Python27/python.exe adobekey.py 
    
  10. You get the adobekey_1.der that you need to run the other script:

     python ineptepub.py adobekey_1.der ~/Path/to/drm_locked.epub your_drm_free_out.epub
    

    For pdfs use 'ineptpdf.py' inststead of 'ineptepub.py'. If you get an error in this step about python, adjust the term 'python', to 'python2' or 'python3'.

  11. You should get the output:

    Successfully decrypted drm_locked.epub as your_drm_free_out.epub
    

Done. Read your epub on any epub reader, e.g., okular, readera, lithium.

To be sure, this is quite a few steps. However, ADE is not a good reader, and the reading experience using wine even worse. I disagree that removing DRM is not legal; for personal use it's perfectly fine to remove DRM from your purchased ebooks. Publishers, of course, have an interest in reducing and controlling access to the material. EFF has some interesting articles on DMCA, DRM, and copyright. Have fun reading.

| |
  • I stopped at step 5. successfully. Thanks for having been so precise in your details!!! This is the best answer to me!! – myselfhimself Mar 25 at 17:02
  • @Ramhound thanks for correcting. – Adam Mar 28 at 6:27
  • 4
    As of April 10 2020 this solution still works! Legal or not, this is what I needed to do so that my 9 year old could read the ebooks provided by the public library on my e-Reader, instead of on a computer screen or smartphone. I think in this case, given current COVID-19 confinement orders, that bending rules like this is appropriate. The kids have to read! – NWMT Apr 10 at 13:00
  • Thanks for the walkthrough! Two small comments: In step 4, you don't need to register an Adobe ID, you can just authorize the computer. In step 10, if you're dedrming a PDF, use ineptpdf.py instead. – Michaël May 21 at 16:32
  • @Michaël, good point. I update that. – Adam May 22 at 18:44
7

I will try to list all the solutions I've found.

First one. Tested solution: working, and very easy.

First install Wine on your Linux. Then download Adobe Digital editions. Link to download Adobe Digital editions

Then, install the file you dowloaded from Adobe (It was ADE_4.5_Installer.exe, for me), in the Wine virtual Window. If you don't know how to use wine, see this doc: How to install and use Wine on Linux

Second solution:

Install a virtual Windows on Linux. How to.

Third solution: If you failed to install virtual machine or open with Wine, and if you really need this program, install a dual boot on your computer Windows/Linux. How to dual boot Windows/linux on the same computer

4th solution, use a virtual Android phone (or a real one) and install the Adobe Digital editions for Android. Virtual smartphone software, Memu

You can also try to emulate MacOs, or iOS.

There are solutions to remove the DRM, and so convert the acsm into epub, but there are no legal, so I don't think I'm allowed to write them.

| |
  • 4
    As all listed "solutions" require installing the ADE software (on different operating systems), and downloading the ePub via ADE with an operational ADE user account... how come you are claiming my comment above to be "not true"? – jvb Sep 12 '17 at 11:13
  • 1
    You seem very susceptible. I was saying "no" to "you can't convert ASCM". I should have say "I disagree" instead of "untrue", but English is not my language. Anyway, it doesn't desserve a downvote from you. Why people seek revenge here rather than peace and communication? It's only replying to a comment to tell my opinion, I didn't kill you nor downvoted you. – Quidam Sep 18 '17 at 8:47
  • "The problem is that I'm using Arch Linux and for some reason Adobe Digital Editions doesn't work for me. During installation it said that it might not work on a 64-bit system." Your solution does not work for the user, as they already said. – Adriano Varoli Piazza Jun 1 '18 at 17:55
3

.acsm can only be used with Adobe Digital Editions and stands for Adobe Content Server Manager.

For more information about Adobe Digital Editions please see http://www.adobe.com/products/digitaleditions/faq/

Side note (may not be generally applicable to Digital Editions users): Stated in the agreement (may be of concern in making a program to access .acsm ) for Adobe Content Server section 11.1 you agree not to:

(d) obtain or attempt to obtain any materials or Information through any means > not intentionally made available through the Services;

Interpret this as you will, I will not give you illegal advice.

| |
  • 10
    Then they should have made a version for Linux – Rob Romijnders Oct 21 '18 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.