While I was trying to connect an Apple Wireless Bluetooth Keyboard through a bluetooth dongle on my PC, I've also downloaded and installed the Boot Camp for Windows (it was an .exe file, so I ran it, because I was curious). Now that I give up trying to connect the keyboard through the dongle, I also want to uninstall the Boot camp program on my Windows. I looked it up several times already, but all posts are about Windows on Bootcamp, not Bootcamp in Windows. Somehow there are no uninstall files nor has the 'Programs and features' the option to delete it, it only shows Change and Repair. How can I uninstall this?

  • The same here :( I've tried msiexec /x .\BootCamp.msi but it fails with "This installation package could not be opened..." error message. Can anyone help here? – Artyom Oct 6 '16 at 12:35

The correct command is msiexec /x BootCamp.msi

Same situation here and I remove bootcamp with this command.


Did that with the help found at that post using Microsoft's troubleshooter from here. Other answer here didn't help.


Worked for me as well. Be sure to launch the command prompt with Administrator privileges and run the command from within the folder where you have bootcamp.msi.

  • 1
    These are excellent details. However, at this point, this is more a comment than a full answer. It may seem redundant in this instance, but please include "What worked for me" as well. As is, this isn't clear from what you've posted (and detailed steps of what exactly worked are helpful - not every step is obvious to everyone.) =) – Anaksunaman May 3 '18 at 5:11

Sorry to necro this thread, but it's the only one I've found discussing this specific issue - and I'd like to leave a trail of breadcrumbs in case anyone else experiences it in the future.

I had this same issue, also on a pc, also trying to get driver support for a mac keyboard. I couldn't use the Command Prompt suggestion b/c apparently there was no .msi file (I also used 7-zip to look into the .exe for an .msi to no avail) - I assume it was a botched install because this isn't a mac. I couldn't use the default Windows add/uninstall programs tool, nor the one linked in other support articles (Microsoft Program Install and Uninstall tool). I tried reinstalling bootcamp hoping to use an uninstall/repair option, but couldn't because .. this isn't a mac - it said the install wasn't compatible with my machine. I have no idea how I managed to get a partial install in the first place, but I assume that's partly why there was no .msi file. I couldn't remove the program because it was running, I couldn't shut it down, and I didn't have any of the standard uninstall options available.

What worked for me was simple, in the end: I opened task manager (ctrl+alt+del) and went to the start up tab. I disabled bootcamp from start up. Which then meant that after restarting my machine, I could go into C:\Program Files\ and delete the boot camp folder (which I couldn't do previously because it was launching at startup). No more boot camp.


The simplest way I found was to run the install package of the original driver version using msiexec /i bootcamp.msi in the command prompt window (as Admin). This repaired anything broken from other removal attempts.

Then in the same window run the uninstall command msiexec /x bootcamp.msi. Worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.