I am trying to install a newer version of Lego Mindstorm, and it's trying to uninstall the older version and it fails. I tried to uninstall it manually and noticed it's not listed Under "Programs and Features" in Windows 10. The program launches fine. I am unable to find the original installer to install it again and get the uninstaller back.

I have Revo Uninstaller, but it shows programs only if they appear in Windows Program applet.

I renamed the folder, but the installer still finds the older version, so I am guessing it's reading the registry. Apart from me trying to find that registry key and renaming it, how can I forcibly uninstall it?

  • I don't see any way other than fiddling with the registry. If you are not comfortable with that then simply delete the folder and run some registry fixing tool such as "Registry First Aid" – Rohit Gupta Jan 18 '16 at 0:21
  • Have you tried to just delete the program directory and install the current version? – Ramhound Jan 18 '16 at 0:33
  • @Rohit I can do the registry thing by using SysInternal's ProcessMonitor to know which key is being read. Looking for a cleaner solution – Tony_Henrich Jan 18 '16 at 0:51
  • @Ramhound I mentioned I renamed the folder. It has the same effect of the installer not finding the folder. – Tony_Henrich Jan 18 '16 at 0:52

You don't see that listed in Program & Features as its entry is missing from




This is what I do when nobody is rushing me :)

  • Remove every entry for the software from Windows installer by searching the following registry keys







  • Remove files associated with it from disk from the following locations

    C:\Program Files\

    C:\Program Files(x86)\




Restart the computer and installation of another version should be fine

You can also use Windows installer Cleanup Utility to remove the software entry from Windows installer.

Don't forget to run the software as an administrator and remove files from disk if you want a cleaner setup as the tool doesn't remove them.

Disclaimer : Windows installer cleanup utility is a Microsoft tool. MajorGeeks is just a trusted download source I use and I am not associated with them


I was able to find the installer on the web.


Try to run the same exe file you used to install Lego Mindstorm, some programs can unnistal the program by running the installation file again and it should give you a feature if you would like to unnistal Lego Mindstorm.

  • The OP specifically said they don't have access to it. – AStopher Jan 20 '16 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.