Please help me the following problems:

While checking system information using msinfo32, I see that Secure Boot State is OFF although I enabled it in UEFI Firmware Settings before.
I also accessed registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecureBoot\State and changed value of UEFISecureBootEnabled to 1 instead 0 as initial.
Then I checked again with msinfo32 is that Secure Boot State was ON and I also tried using Confirm-SecureBootUEFI command in Windows PowerShell to check this but status returned is False.
On the other hand, after rebooting my computer, Secure Boot State is still OFF.

I'm running Windows 10 Pro on Acer Aspire E1-472.

  • Why exactly are you trying to disable Secure Boot?
    – Ramhound
    Jan 18, 2016 at 4:04
  • Are you sure the default Microsoft keys are installed? I had this issue when I tried to enable Secure Boot on my laptop (which, for some reason, shipped with Secure Boot disabled). (@Ramhound: The OP is trying to enable Secure Boot.)
    – bwDraco
    Jan 18, 2016 at 4:08
  • 1
    It would only be off despite being enable if Windows 10 is being booted with Legacy Mode enabled. Yes; Its entirely possible the UEFI would allow you to enable Secure Boot, but still boot into Legacy Mode which of course would automatically disable Secure Boot.
    – Ramhound
    Jan 18, 2016 at 4:09
  • @bwDraco: I tried resetting to factory default setting in UEFI Firmware Settings but the problems still happen.
    – vancanhuit
    Jan 18, 2016 at 5:30

4 Answers 4


You need to set Platform in "User Mode", Secure Boot in "Standard Mode" and Load Setup Defaults.

You could do it by Restoring Factory Keys:

  1. BIOS - Security - Secure Boot - Restore Factory Keys - Enter
  2. BIOS - Restart - OS Optimized Defaults - Enabled
  3. BIOS - Restart - Load Setup Defaults - Enter
  4. Go to BIOS - Main and check if UEFI Secure Boot is ON.

You might be in Setup Mode because you have deleted the Platform Key in your BIOS. Enabling Secure Boot in this state enables your OS to write a new Platform Key (possibly useful for securing a Linux installation). But if you don't do that, you remain in Setup Mode and the Secure Boot State, indicating the Platform Key has been used to secure the system, will remain off.

Your BIOS might have an option to restore the default Platform Key, possibly called "Restore Default Secure Boot Keys", which restores the Microsoft Key. After doing that, your Secure Boot State will be On when booting Windows.

  • Thanks for your answer. In my BIOS, I have an option which is "restore to factory default settings". After choosing this option, however, the problems is still the same as before.
    – vancanhuit
    Feb 8, 2016 at 12:07
  • And do you now see another option, possibly in the security area of your BIOS setup, to delete your Secure Boot Keys ? If you do, you are not in Setup Mode and the assumption in my answer is wrong. Otherwise, if you don't see it and do not see the option to restore the keys either, those options might be hidden in an expert mode or the like. Which options do you have in the UEFI part of your BIOS setup ?
    – Juergen
    Feb 11, 2016 at 10:53

I had secure boot turned on my bios, but Windows 10 said it is off

so what solved the problem is

  1. reset the bios

  2. turn on legacy mode and restart .........that will say no os

  3. go back to bios turn on uefi and reboot...still secure boot off

  4. go to bios disable secure boot and reboot .....secure boot is off

  5. go back to bios and turn on secure boot this time and reboot ......in windows hopefully like me your secure boot option will be on


Get into BIOS > Security Tab > Secure Boot Mode - Custom > Key Management > Restore Secure Boot to Factory Settings - Enable > Save n Exit .

Not the answer you're looking for? Browse other questions tagged or ask your own question.