3

I'd like to install nano on a virtual machine installed with SUSE Linux Enterprise Server 10 SP4. There are no package repositories defined in YaST. What repo URL should I use? I can't find any on the web.

Thank you for your help.

4
+50

I don't know of a repository for this version, but it is still possible to download an ISO.

The name of the ISO is SLES-10-SP4-DVD-i386-GM-DVD1.iso for the i386 version, or SLES-10-SP4-DVD-x86_64-GM-DVD1.iso for the x86_64 version.

Here are a couple of download links that I found using Google :

  • It's sad that these files cannot be downloaded from suse.com anymore... Thanks for the links. I needed the 64-bit version, so I downloaded the second one. I found the MD5 hash of the iso on the web, so I could test it and it was OK. Unfortunately, I could not find nano, only vi and joe were available in the iso. – kol Jan 21 '16 at 13:21
  • Nano can be installed from scratch. – harrymc Jan 21 '16 at 13:31
  • I tried it but make fails with nano.h:93:20: error: curses.h: No such file or directory. – kol Jan 21 '16 at 14:37
  • Perhaps nano-2.0.6 worked once. – harrymc Jan 21 '16 at 15:01
  • I solved it... Using a "version bisection method", I quickly found that the latest rpm which could be installed without problems was 2.1.7. So I did wget http://www.nano-editor.org/dist/v2.1/RPMS/nano-2.1.7-1.x86_64.rpm and then sudo rpm -i nano-2.1.7-1.x86_64.rpm. – kol Jan 21 '16 at 15:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.