I am building a network containing notably a laptop running XP and a computer running Windows 7. Both computer have shared folders and the 7 has a shared printer, to which another laptop running 7 is able to print.

If I attempt to see the laptop's network shares on the PC, everything works perfectly: I am able to see and enter the folders. The reverse operation however doesn't work. Xp doesn't see the Windows 7 PC.

Other things to note:

  • As mentioned above, another Windows 7 computer is able to see the printer and
  • I can ping both computers from either PC.
  • Both computers are in the same workgroup named ALLAITEMENT
  • Password-protected shares are turned off on the PC.
  • The 7 Computer uses 40/56 bit encryption
  • The Windows XP laptop has SP3
  • Did you run the Network Setup Wizard on the XP computer? – Molly7244 Jan 31 '10 at 0:57
  • Just tried. Didn't change a thing. – 3Doubloons Jan 31 '10 at 1:05
  • What's the physical connection between the computers? Are they on a router? Most importantly, is a "Standard Gateway" defined (to find out: Start, Run, type "cmd" and "ipconfig" - the output should list, among others, a "Standard Gateway"). This is important especially for the Windows 7 PC. – Tobias Plutat Jan 27 '11 at 13:22

In the Network Sharing Center on Windows 7, you need to put on the compatibility mode for Windows XP.

Standard, I believe it's set not to be compatible with Windows XP computers...


I had a similar problem, this made it work for me.


Ran into the same problem, this solved the problem for me although it might be unsuitable for your environment. 1) set static IP on the win 7 machine 2) edit HOSTS file on the win XP machine, adding the ip address and the computer name

this enabled me to find the shared folder, use shared printer on win 7 machine but it does not appear on the list of machines in the Network Places


Unfortunately, I was unable to find a proper solution within the timeframe. We ended up installing 7 on the laptop too.


This is probably because the "Password-protected shares" option is disable that it doesn't work... Also, do you have a password on each computer? If there is one computer that have no password on admin account, sharing won't work, for security reasons.

To do it straight forward you must have the same account name with the same password on both computers, then that'll work. I did this for my wife laptop that is running Windows XP and she can access shared folders on my Windows 7 computers without any problems.


You might have a problem with the Server and/or "Computer Browser" services, in which case just restarting those services will solve all your ills.


Most likely it is an issue with the 128-bit encoding that Windows 7 uses. XP is not compatible with it and can't decode the folder contents. To solve this, in the Windows 7 computer under Network and Sharing Center. in the Home or Work profile, set it to allow computers with a lesser encoding to access the shared folders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.