2

I use Synergy as server on a Windows 10, I have rename the pc's hostname as "Al-Windows" (and i have reboot the pc) but Synegy still takes the last hostname :/

The logs :

[2016-01-19T09:02:40] FATAL: unknown screen name `DESKTOP-TO2MEEV'
[2016-01-19T09:02:40] ERROR: failed to launch, error: process immediately stopped
[2016-01-19T09:02:40] INFO: backing off, wait=4s, failures=2

I have deleted and reinstall Synegy but the problem is the same.

Note added by barlop

So, issue is, you get a computer with Windows 10, it comes with a hostname very much like "DESKTOP-TO2MEEV". You put synergy on there and try to run it as synergy server. You change the laptop's hostname and even restarted. Synergy reports FATAL: unknown screen name `DESKTOP-TO2MEEV'. And this is all before and without trying to connect any host to it. Synergy hasn't updated to see the new hostname.

6 Answers 6

3

Go to the Edit->Settings menu and change your Screen Name to the new hostname of your computer. Exit and relaunch the application.

This resolved the issue for me.

Note added by barlop

The above will work. But You don't need to relaunch synergy. Just change that name in edit..settings and stop and start the synergy server. Also, note that in actuality the computer hostname technically doesn't matter, see my answer for an explanation re that.

2
  • It appears you can use aliases as well. Mar 7, 2017 at 6:17
  • 1
    I dont think you need to relaunch the application. just change that and stop and start the server. Also when you do that, then the registry entry and --name that some other answers refer to, will be updated.
    – barlop
    Apr 30, 2020 at 2:30
1

For me reconfiguring the screens again worked to resolve this error. I ensured the name is spelled correctly and dragged the screen to the correct position on the configuration screen.

enter image description here

0

When using Synergy on your server try clicking on the 'Configure Server...' button and having a look at the screens, make sure your screens are named the same as your hostnames for both machines and are aligned the way you intend the use the screen, close the window and press apply and try to connect.

Hope this solves the issue!

0

I tried all of the above with no luck. My environment is a new clean installed Windows 10 Pro (build 1703) running as a server for a Windows 10 pro and Mac Mini clients.

I renamed the server, I believe after installing synergy. I deleted the config I deleted all of the screens from the config server and put them back renamed them carefully. To no avail. I continually got the unknown server Desktop-xx error. Uninstalled, rebooted and reinstalled and rebooted 2 or 3 times. 64 bit and back to 32 bit. :(

[EDIT] I made sure to allow synergy on the local firewall. I have not installed my firewall of choice yet as I said its a new build.

enter image description here

Fred C's post made me wonder why Synergy thought that the PC name was Desktop-xx. So I started searching the reg for that data. Surprisingly, windows used that name in a few places. Given that this was a very fresh install and a roll back would take mere minutes, I changed all of the Desktop-xx to my new machine name. Being careful to note where there was an index after the name eg Desktop-xx0 and leave the 0 (zero). Warning: as always registry tampering could bring on the apocalypse or lesser probs.

**Backups are a part of who we are, create and use them gratuitously!**

Backups are a part of who we are, create and use them gratuitously!

Then I ran into this synergy command line. enter image description here The 0 (zero) at the end matched what my registry had the name as.

Afterwards I could get them to connect but the cursor was clamped to the bottom left. Interestingly, I saw that under display setting Scaling and Layout was set to %125 on both of my 1920x1080 resolution. I changed this to %100 on the server only and things immediately worked. I put it back to %125 and they remained working. shared clipboard is working fine. Drag and drop has never worked for me and still doesn't. I suspect this scaling change reset something needed. Currently on the 32 bit and as its working I will be leaving it alone. I hope this helps any lurkers.

5
  • That registry entry is just a reflection of what you have in edit..settings and after you start the server. Also, the stuff in your answer about the firewall, made no difference so is not relevant to your answer. The things you try that don't answer it aren't relevant to an answer
    – barlop
    Apr 30, 2020 at 2:27
  • @Barlop I simply try to provide a full answer. If the service is blocked it wont work. And Is your answer good today AND 3 years ago? There have been a lot of changes. Respectfully, I do appreciate a response but you are a little late to the party on this one. It's difficult to come in way after the fact and say what worked actually didn't or shouldn't have worked. Apr 30, 2020 at 3:28
  • The question asked about a specific error "FATAL: unknown screen name .........'" e.g. FATAL: unknown screen name `DESKTOP-TO2MEEV' The firewall is not relevant to that error
    – barlop
    Apr 30, 2020 at 3:49
  • You write " It's difficult to come in way after the fact and say what worked actually didn't or shouldn't have worked." <-- I didn't. You implied that the firewall setting wasn't it and I am also saying that. So don't include about the firewall. It's not relevant to the error message he got.
    – barlop
    Apr 30, 2020 at 3:50
  • OK. Apologies then. May 1, 2020 at 17:01
0

The simple answer is go to edit..settings, and fix the screen name there. You'll see that the old screen name that is appearing in that error, is being taken from what is there. So fix that and then stop and start the server and it will be fine. And if the screen name there is fine then make sure it appears on the grid in "configure server".

And infact the computer's hostname is irrelevant to synergy since it isn't used by synergy.. (Though I agree with the idea of giving the computer a useful hostname and having the screen name be the same as that!).

Synergy doesn't actually use the computer's hostname.

It uses what is called a "screen name" which is a synergy specific thing. Every computer's screen name has to be distinct. Each computer has an instance of synergy running.

A computer's / the screen name for an instance of synergy, is under "edit..settings", of the synergy window, on that computer.

And you have screen names under "configure server". The computer whose synergy instance is configured as 'server', has a "configure server" button which shows a window with the grid of screens where you drag pictures of computers onto the grid to represent the computers you want to move your mouse among. Each of those computers has to be given a screen name in that window. Including the server.

The error "FATAL unknown screen name..." happens if the screen name under edit..settings does not exist among the screen names in the configure server window.

And that makes sense, it thinks the server isn't among the group of computers on the grid!

Really synergy should give a more meaningful error message telling the user that they should ensure that the screen name in edit..settings matches the screen name of a computer on the grid. (And of course two computers on the grid can't have the same screen name, that'd give another error, albeit a warning one rather than a fatal one!).

Also I notice some answers say to edit an entry in the registry, but actually when you do edit..settings, then the registry entry with --name that some other answers refer to, will be updated anyway.

-1

The service command line is not updated (not even after a reinstall). Go registry HKLM\SOFTWARE\Synergy\Command change the --name ... done! For the screen name, it's in the current user registry: HKEY_USERS\S-I-D\Software\Synergy\Synergy\screenName

2
  • I could not find this key. However, it did make me search in the rabit hole to find my answer. Sep 12, 2017 at 17:43
  • you are meant to change in synergy edit..settings then start the server. Then the --name in the registry changes
    – barlop
    Apr 30, 2020 at 2:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.