Recently I opened my Control Panel and saw that a blank icon came up before my list of icons. Has anyone else experienced this before? Is it safe to delete it?

enter image description here

When I try creating a shortcut on the desktop, I get a dialog box saying:

Windows could not create the shortcut. Check if the disk is full.

Clearly the disk isn't full, since I still have 102GB of free hard disk space.

EDIT: *I did a manual search for .CPL in Windows Search and then looked at the list in TweakUI and got 3 unmatched .CPL files. They are ncpa.CPL, sapi.CPL, and QuickTime.CPL. I clearly know the QuickTime one, but not too sure about the rest. SCRATCH THAT, I FIGURED IT OUT... BUT IT'S NOT THE BLANK ICON.

  • Did you install some nLited XP rip or is this a full Windows XP SP3 installation? – Molly7244 Jan 31 '10 at 20:31
  • It's a full XP SP3 installation... I've been running it for many many years now, but this icon has disappeared on its own for some reason... – Wesley Jan 31 '10 at 20:53

TweakUI has an option to "Rebuild icons" - have you tried that?

Here's a standard set of icons:


If you are not missing any of the system icons above, and you don't know what the phantom icon is, then by all mean get rid of it! TweakUI can hide it so you can forget it. You could possibly succeed in a hunt for the CPL file in your Windows folder, but I don't know if deleting the CPL is enough. There could also be registry entries somewhere.

  • So I have all of the standard icons, plus a whole bunch of 3rd party ones, such as Indexing Options, Java, Mail, Model Settings, NVIDIA Control Panel, Panda Cloud Antivirus, Software Explorers, Sound Effect manager, V.92 features settings, and Windows CarSpace. Still, if it was third party, wouldn't I be able to copy it somewhere else and open it up in Notepad to get a hint at what it came from? – Wesley Jan 31 '10 at 19:11
  • The control panel can't be expected to behave like a file folder, since its not really a file folder - it just tries to look like it. I guess your hope is finding another software that lists your control panel icons and happens be smarter than windows (TweakUI was mentionned in that regard). Otherwise you've simply got a control panel haunted by a benevolent ghost. – mtone Jan 31 '10 at 19:41
  • So, that blank icon isn't listed in TweakUI. Would that mean I should delete it and just see what happens? – Wesley Jan 31 '10 at 19:59
  • Okay it's gone now... no clue how... – Wesley Jan 31 '10 at 20:54
  • Really? Good for you then! – mtone Jan 31 '10 at 21:19

I'm going to go out on a limb here and say it's a control panel that was part of a third-party application that is either no longer installed or is corrupted. In any case, you can't really just "delete" a control panel icon. TweakUI will allow you to remove icons.

Here's a good web site that will get you up to speed:


Good Luck!

  • Hmph... I'd still like to make sure that it's 3rd party before I get rid of it. – Wesley Jan 31 '10 at 6:23
  • Okay it is 3rd party, but can't be deleted. It doesn't leave the Control Panel... UGH. – Wesley Jan 31 '10 at 20:02
  • Well it has disappeared without warning, but thanks for introducing me to TweakUI haha – Wesley Jan 31 '10 at 20:59

Control Panel icons are actually programs renamed to have the extension ".CPL". You should be able to find out what program is represented by this icon by searching your C:\Windows\System32 directory for *.cpl. Exclude the known Control Panel applets (e.g. Internet Options) and you'll have this one.

It would seem that one of these programs has no embedded icon. I would not be surprised to find that there is some program that was accidentally given a name ending in ".cpl" but is not actually meant to be a Control Panel applet and therefore isn't working right.

  • How would you exclude known ones... they're not exactly named like that. Also, there's doubles of each and some triples, so how could you tell, say, if one of the doubles/triples was the blank icon? – Wesley Jan 31 '10 at 6:23
  • Perhaps a search for all CPL files sorted by CREATION date could give you a clue? – mtone Jan 31 '10 at 7:58
  • I did... last one was last month, but nothing really happened at that time. It's called inetcpl.cpl. – Wesley Jan 31 '10 at 19:12
  • Which using TweakUI is the Internet Control Panel... How would that be correlated with a blank icon? – Wesley Jan 31 '10 at 20:02

do you still see this after a restart? and how do you want to delete it? I personally never saw this before. Perhaps a uninstallation didn't clean up completely. I think you can just remove it. You should be able to remove it by changing a few things in the registry (google should help you :D)

  • Yeah, I restarted and it stuck. I do have the option to just delete it, except I'm scared that I will delete something that I can't recover. – Wesley Jan 31 '10 at 5:43
  • If you make a restore point and delete the icon you'll be able to undo any potential damage. – outsideblasts Jan 31 '10 at 7:23
  • Okay... system restore point made. But I can't even delete it... It just sticks. – Wesley Jan 31 '10 at 20:01

Can you try this?

  1. Download Shell Object Editor.
  2. Right-click on the grid and switch to expert mode.
  3. Order the display by Location.
  4. Look for the rogue entry in the list with the location set to "control panel (all users)" and delete it.
  5. Restart.

Actually I have had this happen before when I was going through another person's machine. They had contracted the Anti-Virus 2009 malware infection that was going on at the time. Several fake icons were dropped into the control panel along with a handful of popup windows in the notification area. Because you're having problems in creating a shortcut on the desktop also, I would suggest that you go through and start running some anti-virus scans, check out your applications set to run on startup and see if there are any rogue processes running on the machine.

Check out Jeff Atwoods blog post on how to hunt down and remove a virus infestation.

Good luck and hope this helps you out some.

  • I don't think it applies to me. I ran 2-3 virus scans... AVG, Panda Cloud and Defender... and nothing. And even using that Process Explorer, I knew what processes were going on. I don't think this happened as a result of virus infestation.... – Wesley Jan 31 '10 at 6:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.