1

I would like to keep my time up to date using an online NTP server. pool.ntp.org seems to work for other devices on the network, so that's the NTP server I want to use.

When I update the NTP server and click Update now, I always get the following error An error occurred while windows was synchronizing with pool.ntp.org. When I close the screens and re-open it, it says Windows successfully synchronized to time.windows.com on ..., even though it didn't..

In the Event logs I can find the following message: The time provider 'VMICTimeProvider' has indicated that the current hardware and operating environment is not supported and has stopped. This behavior is expected for VMICTimeProvider on non-HyperV-guest environments. This may be the expected behavior for the current provider in the current operating environment as well.. Just to make things clear, I am NOT using a VM.

Not sure if it's got something to do with it, but I am unable to install the KB3124263 update.

What have I tried/checked?

  • w32tm /resync
  • w32tm /unregister-register
  • net stop-start w32time
  • Windows Time service is set to Automatic and is running
  • added FW rules for ports 123 UDP (incoming and outgoing)
  • I can ping pool.ntp.org and tried other ntp servers too (same error)
  • "I am unable to install the KB3124263 update." - This does indeed sound connected. If you have Citrix XenDesktop installed that might be the reason it is failing. – Ramhound Jan 19 '16 at 15:06
  • @Ramhound, it's just a standalone W10 PC, nothing special – CustomX Jan 19 '16 at 15:08
  • Have you used any tools or used any commands to disable Windows 10 features or services that might have changed the way Windows 10 communicates with the NTP servers in question? – Ramhound Jan 19 '16 at 15:19
  • @Ramhound, none that I can recall. It was a clean install and only has IP camera software on it. I need an NTP server to make sure the time is synchronized on the cameras, storage and viewing software. – CustomX Jan 19 '16 at 15:24
  • Like I point out. Your inability to update Windows 10 is likely connected to your inability to communicate with your NTP server. Solve the update problem and you likely will solve both problems. – Ramhound Jan 19 '16 at 15:31
2

It sounds like you have a problem reaching "pool.ntp.org" and so it is continuing to use "time.windows.com" because synchronizing with that time source is working.

You can get more details on why it may be failing by enabling the debug log file.

w32tm /debug /enable /file:c:\temp\ntpDebug.log /size:102400 /entries:0-300
w32tm /resync
REM *** Wait 60 seconds
w32tm /debug /disable

Then open ntpDebug.log with Notepad. Look for a message that explains a problem, and/or edit your original post with the contents of that file.

  • Craig620, I removed Meinberg NTP server and now I can successfully connect to pool.ntp.org, but can't connect to a local NTP server. I have the debug file, but I'll need to create a new question. – CustomX Jan 20 '16 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.