1

I know that I can change it, but it doesn't last, I need set to Occidental and when I re open the navigator is set again to Unicode.

  • What version of Firefox, and what language are you trying to keep as default (there is no "Occidental" in recent versions). Also, any web sites or specific one(s)? – user3169 Jan 20 '16 at 3:31
  • @user3169 42.0 in Spanish Ver->Codificacion de texto->Occidental. In English maybe is View->Text encoding->Western – E_Blue Jan 20 '16 at 12:15
  • Nowadays most websites use Unicode (UTF-8) encoding, so this is hard to check without a web page using a different encoding. If you check the web page source code (Ctrl+U) you will usually see a line like "<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />". If UTF-8, there is no need to change the encoding. If a different charset, Firefox should detect and change automatically. If not defined, it will default to the settings in Options --> Content - Fonts - Advanced. I don't know a non UTF-8 site at the moment, but if you add one or two to your question I can test it. – user3169 Jan 20 '16 at 19:10
  • 1
    So Firefox is using the page Text Encoding to decide its setting, not the meta tag. Windows-1252 is the same as iso-8859-1 (as mentioned in the linked article), so Isle of Pines works correctly. But Text Encoding and meta tag do not match on your site. So it seems to be a problem with that website. – user3169 Jan 23 '16 at 5:13
  • 2
    Not that I know of, since there is no preference to set the default differently. You could ask the site technical support why this is. I am not a server IT guy, but it seems strange that the server is UTF-8 but the text they are pulling from a database is Western. – user3169 Jan 25 '16 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.