I have this seemingly simple problem and I can't figure out how to solve.

I have a small exe I created myself and I would like to run it directly from an USB drive or external HD.

I can use it if I copy it onto a local directory, but this issue has left me stumped, I would like to run it directly without having to copy it around :)

The error that pops up states that Windows cannot access the specified device, path or file and that I may not have the required permissions. (I am the administrator, also running the exe as administrator renders the same error)

Is there a way to achieve this?

  • Is it possible that the exe is requiring libraries using a relative path instead of an absolute path?
    – jcbermu
    Jan 20, 2016 at 14:23
  • It is as simple as putting the executable on the external drive and running it. What file can the application not access specifically?
    – Ramhound
    Jan 20, 2016 at 14:24
  • That could be the problem, it's a C# program, so it could be accessing some .NET library, but those reside on the computer, and are accessible to anyone, I think. Jan 20, 2016 at 14:46
  • 1
    troubleshoot. Create a file named blah.exe and run it and see if you get the same error. Try other EXE files. Quote the error message's exact words, because googling it requires the exact wording. And then you can also try to improve your terribly useless title.
    – barlop
    Jan 20, 2016 at 15:24
  • In addition to barlop's suggestion (try other EXE files), try finding out: What permissions are specified on the directory? (It could specify that user doesn't have Execute permissions.) I see barlop already adjusted the previous title that he was commenting on.
    – TOOGAM
    Jan 20, 2016 at 15:35

1 Answer 1


I have found why I could not open any .exe files, there was an Antivirus restriction that remained active even after turning off active protection on removable devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .