3

Every time I start typing a search string into the Chrome omnibox which starts with "github", Chrome turns it into a site-specific search (see attached GIF).

This only seems to happen for GitHub. I don't think this is due to an extension because it even happens in incognito windows. This effectively makes it impossible to search for anything starting with the word "github".

How can I disable this behavior?

enter image description here

  • Have you uninstalled or disabled the add-on to verify it is without a shadow of doubt not cause by an add-on? This does not happen to me. – Ramhound Jan 20 '16 at 20:20
  • I disabled all extensions (screenshot) then restarted Chrome. The undesirable behavior still happens. "About Google Chrome" shows "Version 47.0.2526.111 (64-bit)". – tboyce12 Jan 20 '16 at 21:08
3

In Chrome's Settings, Search, Manage search engines under your entry for github change the middle field (Keyword) to something that won't so readily capture github search.

E.g. change github to github.com or search_github.

The keyword field is used for the trigger to invoke the particular search engine.

1

Credit goes to https://stackoverflow.com/a/33590538/1529675

This behavior can be caused by a "Custom Search Engine" in Chrome preferences. Go in to Settings, Search, then Manage search engines, then scroll down to find and remove Github (or the offending specific site).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.