If you open more than one tab in Safari running on Windows 7, they show up as if there are multiple windows, while technically, they are not windows, just tabs inside one window.

I think this behavior is not usual compared with other browsers like Firefox or Chrome or any other application for that matter.

Any idea why this happens or is this a bug?

Safari version: 4.0.4

  • Have you managed to get around this bug ("feature") somehow?
    – WhyNotHugo
    Mar 28, 2012 at 13:34

4 Answers 4


This is by design. Each tab gets its own thumbnail preview in the Taskbar, so you can switch faster to the desired tab.

Internet Explorer 8 does the same, and it's possible with Firefox 3.6 too: Unlock thumbnail previews for Firefox 3.6 on Windows 7

Internet Explorer 8:

alt text

Firefox 3.6:

alt text

Apparently it's foreseen in the version 5.x of Google Chrome.

  • okay...now it makes sense.
    – detj
    Jan 31, 2010 at 15:44

This is a taskbar enhancement that is available in Windows 7 for applications that are Windows 7 aware and can inform the OS that there are internal contexts that can benefit from displaying multiple views to the taskbar. Chrome and older versions of Firefox don't do this but IE8, Office 10 apps, Firefox 3.6 and the current version of Safari do. Newer version of apps wil lincreasingly support this and other Windows 7 Superbar features like context menu jumplists.

  • Actually, firefox doesn't do this by default, you have to manually enable this mis-feature.
    – WhyNotHugo
    Mar 28, 2012 at 13:33

As found on http://www.twikid.com/is-there-a-way-to-not-make-the-safari-tabs-appear-on-the-taskbar-in-windows-7/

Run Safari in XPSP3 compatibility mode as administrator to make it behave properly.


You can set the Safari program properties to run in Vista (SP2) computability:

[I had an image to post but this site will not allow me to include it.]

You do not need to select the "Run this program as an administrator" as reported in an earlier post.

This may be a design feature of Windows 7 (one that I do not like) however even IE9 allows you to disable this in the Internet Options.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.