1

i need change default runlevel to ubuntu server 14.04. I installed GUI to manage the hp printers and now i need return to runlevel 3, i edit the file /etc/init/rc-sysinit.conf and modify the line:

env DEFAULT_RUNLEVEL=2

to

env DEFAULT_RUNLEVEL=3

But every boot start in graphical mode

5
  • Did it worked sudo init 3 ? The default place in RH were ` /etc/inittab` if I remember well. I see you have done as suggested here. – Hastur Jan 21 '16 at 14:09
  • yes, but it happens nothing – hellb0y77 Jan 21 '16 at 14:11
  • You may find interesting to read this answer for grub setting of the RUNLEVEL. Why did you change the default level and not only the current one? BTW the differences between RUNLEVEL 2 and 3 is the network support. – Hastur Jan 21 '16 at 14:31
  • OK, how stop the graphical mode on boot? – hellb0y77 Jan 21 '16 at 14:36
  • Please make it more clean, do you mean the X display manager? In case which is (lightdm...)? Search directly for the one you need. PS>I don't know if your Ubuntu has a SystemV or upstart as it seems. They have different RUNLEVEL 3 meanings. If your question is different from the one you posted, please edit it. – Hastur Jan 21 '16 at 14:48
0

I resolved adding text to line in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="text"

type after:

update-grub

and reboot, now works!

1
  • So you forced it from grub. Good. Glad that the answer about the grub setting of the RUNLEVEL pointed you on the right direction. Please edit your answer and add some reference that you found of the value admitted for GRUB_CMDLINE_LINUX_DEFAULT it can help someone else too. :) – Hastur Jan 21 '16 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.