3

I have an HP Pro x2 running Windows 10 Enterprise x64. It has a Verizon SIM card and under Settings > Network & Internet > Cellular, it has Verizon Wireless (LTE) listed as Connected. Under Settings > Network & Internet > Wi-fi, it has the switch set to on.

Under Control Panel > All Control Panel Items > Network Connections > Cellular, I've right-clicked and selected Properties > Sharing; there I've checked the box for “Allow other network users to connect through this computer’s internet connection.” In its dropdown, I've selected "Wi-Fi". Current network connection is via the cellular SIM card and it works fine by itself.

Now, under Settings > Network & Internet > Mobile Hotspot, I click to turn on the hotspot, but it switches to off immediately and says:

We can't set up mobile hotspot. Turn on Wi-Fi.

The cellular network adapter info is as follows:

Manufacturer:   HP
Model:  HP lt4211 Gobi 4G Module
Firmware:   T77H468.V.3.2.7.2
Network type:   GSM

The SIM card doesn't have a PIN (it's blank). What am I missing? I've updated the driver for the HP Gobi Module from HP. In addition, I've modified the registry with the following changes so it allows me to have access to the hotspot feature:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Network Connections]
"NC_PersonalFirewallConfig"=dword:00000001
"NC_ShowSharedAccessUI"=dword:00000001
"NC_AllowNetBridge_NLA"=dword:00000001

Thank you.

14
  • Do you have the OEM Bloatware that handles the WiFI for Windows, if you do, get rid of it then try. – Ramhound Jan 21 '16 at 14:20
  • Thanks, @Ramhound. How do I do that? – Alex Jan 21 '16 at 14:22
  • Are you asking how you confirm if your installation has OEM Bloatware on it? – Ramhound Jan 21 '16 at 14:22
  • I guess both: how to confirm and how to get rid of it. – Alex Jan 21 '16 at 14:23
2

Found this solution for those who are wondering. First, I have the following in a .reg file (I'm aware that the last modification is not recommended by sys admins):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Network Connections]
"NC_PersonalFirewallConfig"=dword:00000001
"NC_ShowSharedAccessUI"=dword:00000001
"NC_AllowNetBridge_NLA"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"DisableBkGndGroupPolicy"=dword:00000001

Then I have these commands in a .bat file:

REM ----- Run regedit silently to add the necessary network sharing settings -----
regedit.exe /S NetworkSharingSetup.reg

REM ----- Add the hotspot -----
netsh wlan set hostednetwork mode=allow ssid=Hotspot1 key=123456

REM ----- Start the hotspot -----
netsh wlan start hostednetwork
REM ----- Show the hotspot details -----
netsh wlan show hostednetwork

timeout -t 10 /nobreak

REM ----- Bounce the Cellular connection -----
netsh interface set interface name="Cellular" admin=disabled
netsh interface set interface name="Cellular" admin=enabled

pause

I ran into an issue where, after starting the hostednetwork, my cellular connection kept connecting and immediately disconnecting in an infinite loop. I discovered that if I waited (timeout) and bounced the connection, it fixed the issue. Not sure why the cellular connection got into this status or why the wait was required.

After creating this batch file, I create a shortcut to it, then right-click > Properties > Shortcut tab > Advanced > check the box for "Run as administrator". This is required for the lines where we bounce the cellular connection.

One final thing: During this process, the tablet was kept off the organization's domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.