1

Symptoms

I have created a Debian live system on USB stick. The content is a hybrid ISO image (type iso9660). This operation has been successful since the pen-drive does its job in the same desktop where I created it. This desktop runs on Ubuntu 14.04 LTS.

However, the same pen-drive is not recognised by the boot manager in my laptop, a recent Acer Aspire V11 Touch (aka V3 112P P2E7). For sake of completeness, the laptop runs on a dual-boot system with Fedora 22 as primary OS and Windows 8.

The boot manager in the laptop is InsydeH2O Setup Utility Rev 5.0. There, the boot mode is UEFI, Secure boot is enabled and the top entries in the boot priority order are:

  1. USB FDD:
  2. EFI File Boot 0: Fedora
  3. HDD: ...
  4. ...

First diagnosis (Debian only)

The device is not even recognised by the boot manager for the following reason.

Inside the boot manager I can explore the directory tree through the option 'Select an UEFI file as trusted for executing'. The first idea was to access the pen-drive content and grant permission to trusted file there.

However HDD is the only drive showing up. Based on previous experience I expected to see HDD and USB0 though (for context, in a little digression, you may look up Issue 2 in the answer to this post on Ask Fedora).

Moreover, the result of a few explorations is the following:

  • if I only change the boot mode to legacy, the boot process does not even proceed;
  • if I only change secure boot to disable, same symptoms as above;
  • the laptop has two USB ports. Down the line Fedora recognizes the pen-drive on both ports. So the hardware should be OK.

Second pass (Debian vs Fedora)

I have double checked whether a problem resided with the creation of a bootable USB stick. This is documented in one other post on the Unix&Linux forum. Tapping from different sources I have done the following:

  1. Created a new gpt-type partition table on the USB stick;
  2. Formatted the device as fat32;
  3. Copied the ISO image to the USB drive with dd if=<location iso file> of=/dev/sdX

I repeated this procedure with two ISO images:

  • the Debian image (debian-live-8.2.0-amd64-gnome-desktop.iso)
  • a Fedora image (Fedora-Live-Workstation-x86_64-23-10.iso)

With Debian, the situation is precisely the same as in the first diagnosis.

With Fedora,

  • unlike Debian, the boot loader sees that there is a USB stick I can select a trusted UEFI file from; this is an improvement;
  • however, if I mark the efi files in the stick as trusted, the priority order is neglected all the same at boot time;
  • thus, like Debian, I don't manage to boot from USB either!!

This seems to suggest that

  1. the USB stick, seen as storage, is fine;
  2. the contents of the ISO image plays a role;
  3. this UEFI boot manager is pretty hard to play with.

Questions (rephrased)

Do you also think that the problem is that the boot manager cannot handle the USB stick?

Current evidence. The boot manager does so in different ways: with Debian it does not recognise the stick, with the Fedora image it disregards that

How can I get to start the live system from the pen-drive in this situation?

Current target. I would be happy to get the Fedora live system being loaded in order to pin down a solution strategy. After all the current Fedora was installed this way!

Thanks for thinking along.

  • 1
    Did you ever try legacy on and secure boot off. That usually works. – whs Jan 22 '16 at 1:37
  • Not applicable to this boot manager, unfortunately. The choice secure/insecure boot is active only when boot mode is UEFI. Legacy boot mode means no further chance to toggle any security status of sorts, as far as I can see. – XavierStuvw Jan 24 '16 at 15:26
  • I have seen computers which are able to use only some USB ports at boot. At those occasions the unusable USB ports have been USB3 and the useful ports have been USB2. – Henrik Carlqvist Jan 24 '16 at 16:08
  • I am sieving several forums and tend to think that my bootable USB does not have specific UEFI features that make it seen from the boot manager. This one boot manager does not have anything like a compatibility mode, so probably it's the pendrive that has to be made fit for purpose. – XavierStuvw Jan 24 '16 at 16:28
  • I have substantially edited the question. The latest evidence is that the content of the images play a role since the boot loader responds differently to a Debian or Fedora iso. However the boot priority order is disregarded either way, so booting from USB stick is still impossible. – XavierStuvw Jan 25 '16 at 18:23
0

The problem has two facets.

The boot loader does not recognize the USB being plugged in

My evidence is that this issue happens with the ISO image of Debian and namely debian-live-8.2.0-amd64-gnome-desktop.iso taken from this repository.

In contrast, the boot loader recognizes whether a USB stick is plugged in when this is a live system of Fedora 23. Namely Fedora-Live-Workstation-x86_64-23-10.iso from this website.

This problem has to do with the ISO image and is matter for another post. What follows has then been tested with the latter image.

The boot priority order is ignored

Strange but true, the outcome proved to be dependent on how far the Fedora boot loader is from the top. NB This one Fedora (22) is the OS up and running in the laptop and is another thing than the Fedora (23) image in the USB stick referred to above.

The bootable USB stick has been successfully recognized if the order is

  1. USB FDD
  2. HDD
  3. USB HDD
  4. USB CDROM
  5. EFI file Boot: fedora
  6. Windows Boot Loader
  7. Network Boot-IPV4
  8. Network Boot-IPV6

The bootable USB stick could not recognized until the order was

  1. USB FDD
  2. EFI file Boot: fedora
  3. HDD
  4. USB HDD
  5. USB CDROM
  6. Windows Boot Loader
  7. Network Boot-IPV4
  8. Network Boot-IPV6

The logic of this escapes me. Also, it not granted that the distance from the top of the Fedora loader is the true discriminant -- this rather describes how I found out this workaround.

Using the command efibootmgr -v provided good guidance to notice certain discrepancies between the priority order set in the boot loader and that living once the operating system had been loaded.

So long as I am right thinking that USB FDD means USB stick, there is some issue either with the boot manager (InsydeH2O Setup Utility Rev 5.0) or with the operating system (Fedora 22) or with both.

Corollary over legacy booting mode and security

Actions such as setting the booting mode to legacy or disabling secure booting are not relevant to this problem. All can stay at default values.

Happy to be corrected and to receive integrations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.