2

When I try to type a question mark character (shift-/) on my Samsung Chromebook, I get an underscore. Other non-letter characters are wrong too.

I haven't had the machine for long, but I think it worked initially, so perhaps I've hit a keyboard shortcut and changed it by mistake?

How can I get it back working correctly again?

2
  • 1
    Have you tried a hard reset? Or looking at the settings > show advanced settings > languages > language and input settings? The second one should most likely show some strange setting, just change it to whatever is normal for you. Jan 25, 2016 at 10:38
  • if you can back up the files which it appears like this doesn't seem like that big of issue. Just restore to factory settings or do a hard reset.
    – William
    Jan 29, 2016 at 6:40

6 Answers 6

3
+50

You probably have changed your keyboard layout inadvertently. You should check your keyboard configuration settings under the language and regions section in the control panel. There you will be able to see if your configuration has changed, and change it back if it has.

0

Found this:

You will need to do a hard re-set. Perform this by holding the Refresh key (the key that has an arrow in a circle shape on the top row of keys, and pressing the Power button for one second, then releasing both keys at the same time.) Although this does use the keyboard, these keys are set to trigger these even when it's unable to work.

And this - Gives instructions for the above based on model.

Hope it helps!

3
  • What's lost when a hard reset is done? Thanks Jan 26, 2016 at 20:49
  • 1
    Ok, directly from a Samsung worker: "Performing a Powerwash or reset will erase all local data. Prior to performing a Powerwash it is recommended that you backup any important data using a USB drive, SD card, or Google Drive." I will double check for another solution. @HighlyIrregular
    – z7r1k3
    Jan 26, 2016 at 21:10
  • @HighlyIrregular So you basically have two options: 1) you can go ahead with the reset, and 2) you can let me know, and I'll download a chromebook os on vmware and see if I can find a way to repair your keyboard driver. However, I highly doubt the latter will be productive.
    – z7r1k3
    Jan 26, 2016 at 21:21
0

To resolve the problem for my case, the following steps were required:

  1. Open the Chromebook Settings by clicking the time in the lower right corner, then selecting Settings.
  2. Scroll down to the bottom of the window and click Show advanced settings
  3. Scroll down to the Languages section and click Language and input settings
  4. Under Input Method none of the options were selected, and selecting US Keyboard fixed the issue. Note that it wasn't clear which option should be selected, or that any option needed to be selected at all.

I had connected a Logitech wireless keyboard to the Chromebook recently, so it's possible doing that caused the setting to automatically change. When I first used the Chromebook I'm sure the problem didn't occur.

Note: Nick P's answer was largely correct for solving the problem, though a hard reset as suggested by Spencer4144 probably also would have worked (though potentially with the loss of other settings and downloaded data). Nick's answer might be best left as a generic answer, so I've added my own but have awarded him the bounty I offered.

0

It was set on "UK Keyboard," so every time I typed @ it came out as ". Switching to "US keyboard" worked. In the lower right corner you will see time, volume, wi-fi, and battery. At the end of that string of icons are letters that indicate the keyboard setting. Click on it and change it to "US Keyboard."

Easy!

0

I had a similar issue, but mine was with the letters. Not all letters were switched, but the majority. I had to figure out what letters it was giving me so that I could login and check the settings. Under the language and input settings, someone had changed the input settings to US Workman Keyboard instead of just US Keyboard. Once I changed it back, it went back to normal. Hope this is all it is for you!

I know the original post was from almost two years ago, but I thought someone else may find this in a search like I did.

0

I had this problem and I just changed the language on Advanced Settings to English (UK) rather than English (US) and the keys went back to usual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .