3

I created an FTP server on my local Windows 7 machine with IIS.

I can connect to the server with the machine on which I created the server, but I can't connect to the server with my laptop which is in the same local network as the machine with FTP server on it.

I configured passive mode in FileZilla and port forwarding on the router.

But the problem is always the same:

Connection timed out

Any ideas?

  • 1
    Any software firewalls on the machine? Have you checked IIS is listening for all IP's? Port forwarding is not necessary within the same local network. – Jonno Jan 22 '16 at 8:44
  • Yes it was the firewall problem. Thank you for help. – Matic1911 Jan 23 '16 at 20:55
5

The connection is most probably blocked by the Windows firewall.

While the Windows firewall is automatically configured with rules for the ports 21, 990 and 1024-65535, when IIS FTP server is installed, the rules are not enabled initially.

To enable or change the rules, go to Control Panel > System and Security > Windows Firewall > Advanced Settings > Inbound Rules and locate three "FTP server" rules. If the rules are not enabled, click on Actions > Enable Rule.

For details, see my guide for Installing a secure FTP server on Windows using IIS.

  • Thank you for that it works now! Do you know how can I configure client to use only port 21? Because now I have passive mode enabled and ports between 50000 - 51000. – Matic1911 Jan 22 '16 at 15:54
  • You are welcome. Though on Super User we thank by accepting the answer. – Martin Prikryl Jan 22 '16 at 15:55
  • Can you please see my updated question? – Matic1911 Jan 22 '16 at 15:56
  • The problem is that when I connect from client with FileZilla the port is random between 50000 - 51000. I need port to be 21 because I wrote a proxy for educational purpose and I would like to listen to traffic. – Matic1911 Jan 22 '16 at 16:01
  • FTP protocol needs a separate port for data connections. You cannot do with only port 21. You can reduce the data connection port range to a single port number. But it has to be distinct to 21. – Martin Prikryl Jan 23 '16 at 8:11

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.