I have a java scanning app run on my computer every day and every time it runs I'm getting this warning


In more information:


I've checked the certificate and the app is signed (Thawte is a root CA)

I'm looking at this info on java page: http://java.com/en/download/help/appsecuritydialogs.xml

but no luck with disabling this message.

Some examples on that page have this option: "Do not show this for apps from this publisher". I'm not getting this check box.

Java version: 1.8.0_66

OS: Windows 8.1

  • Are you connected to a domain, if you are, are you an Administrator? If you are not connected to a domain are you running this application as a User or Administrator? If your prompt is missing an option it normally means you are not running as a non-elevated user. – Ramhound Jan 22 '16 at 14:47
  • Sorry for late reply. Yes, I'm getting the same screen when I'm running the scan as regular user and when I'm running the scan as Administrator (in both these cases I'm not connected to the domain). – morholt Apr 2 '16 at 9:08

Had the same question when I stumbled upon yours here.

After some research, the best I can come up with is this from Oracle:

Why don't I see the option to select Do not show this again for this app in the security dialog for an unsigned application? Starting with Java 7 Update 40, the option to select Do not show this again for this app is no longer available. Unlike previous versions a user cannot suppress the security dialog for an unsigned application and will have to select the option, I accept the risk and want to run this app, each time to run the unsigned application.

Source: http://java.com/en/download/faq/signed_code.xml

Prior to Java 7u40, there was a checkbox which said “Do not show again for this application” … which would make the dialog not appear again unless certificates were changed or a new version of the applet was deployed.

Interestingly, the specific release notes don’t mention this change: http://www.oracle.com/technetwork/java/javase/7u40-relnotes-2004172.html

Since this pre-dated Java 8, it's likely you were running an older Java 7 version and then started to notice this behaviour when you upgraded to Java 8.

I did poke through the Control Panel options and there does not seem to be a way to work around this.

So, if I've understood correctly, it is unavoidable to have this message display every the app is launched.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.