2

When I open up Control Panel -> Keyboard -> Layout and click Show... the two keys left from '1' and left from 'z' are mixed up. This happens both on my Macbook Pro (mid-2012) keyboard and my external Apple aluminium keyboard. I'm running Linux Mint Debian Edition 2. My layout is set to 'Swedish' which gives me my åäöÅÄÖ and proper mappings according to both my physical keyboard layouts.

I've tried setting different keyboard models but all seem to generate the same problem, my guess is that Apple has changed the firmware and it's being misinterpreted by Linux.

Is there maybe a way to customize the way keystrokes are mapped to 'key-meanings' under LMDE2?

EDIT: My laptop keyboard does the right thing with these settings, my aluminium keyboard still mixes it up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.