1

I'm getting an import error "failed to load module MSVBVM60.dll" when opening a program called theRenamer after updating to Windows 10. It's strange in that I wasn't getting it at first, but now it seems to be occurring regularly.

I've looked at a few different solutions on getting it to load. I downloaded a copy of the DLL and put it in that programs folder and the system32 folder. I ran regsvr32 with elevated comand prompt in system32 and targeting the file I put in theRenamer's program folder. I tried installing the latest Visual Studio and Visual Studio Runtime 6. No luck.

The only other thing I can think of is formatting everything and starting over.

  • You're probably missing a dependent module. Have you tried using Dependency Walker to eliminate that possibility? – rrirower Jan 22 '16 at 16:04
  • Will try when I get home from work. – John Jan 22 '16 at 16:23
  • Tried this. Gives a bunch of errors. Not really sure what I'm looking at. – John Jan 22 '16 at 22:29
  • The errors usually indicate missing dependent dlls. – rrirower Jan 22 '16 at 22:31
1

I just got the same error after the latest windows update, restarted the machine yesterday after 31 days uptime. theRenamer worked fine since I updated to win 10,up until the last update... I also tried installing a visual basic service pack, witch made the program start once, 2nd time I got the error again. Maybe it's needed to install the visual basic program login' in as the actual administrator user in Windows, gonna try that when I get home.... It has nothing to do with a dependent module as rriower said.

  • Thanks (though this is more of a comment than an answer). I'm logged in as administrator. The fact that it worked once and then stopped working suggests that something might be breaking on restart. – John Jan 22 '16 at 22:30
  • Well it might be that Windows won't allow changes to the system files, John are you using the actual administrator account, and not just another user with admin rights – Mortyfar Jan 22 '16 at 22:34
  • Windows has a default administrator account witch is usually disabled, another user with admin rights doesn't have all the access as that account has – Mortyfar Jan 22 '16 at 22:37
  • I'm pretty sure I'm the only user and I have admin rights. Unless I have a clear solution, I don't want to re-install Visual Studio multiple times because it takes forever. – John Jan 22 '16 at 23:03
  • 1
    I found the solution, and it's so stupid, but it works, right click the shortcut for theRenamer program, choose "troubleshoot compatibility" follow the instructions and boom... That solved it for me, hope this helps you as well :-D – Mortyfar Jan 22 '16 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.