3

I'm using ConEmu (specifically Cmder's version). Running 'cmd', it supports 256 colors (top).

However, I can't get other programs to run in 256 color mode. I've tried Perl (middle) and ls (bottom), but both run in 8/16 color mode.

Cmder - 256 vs 8 color mode

Any suggestions on how to fix this. Mostly I'd like ls to work in 256 color mode.

0

Actually, the official docs contains all answers:

Why not to read them?

To enable 256 colors in ls you have to run cygwin/msys connector and disable backscroll buffer with -cur_console:h0 while starting your task. Of course, that must not be {cmd} task, but {bash} task with connector.

3
  • I think I have the settings right: 'TrueMod (24bit color) support', 'ANSI X3.64 / xterm 256 colors’, and ‘Inject ConEmuHk’ are all enabled. I can' find where to turn off scrolling. perl 256colors2.pl -cur_console:h0 produces the same output as above, except now the first line of the prompt is printed twice. – MinchinWeb Jan 30 '16 at 0:23
  • With the second part of your comment, are you saying that 256 color mode for ls only works on {bash} and not {cmd}? – MinchinWeb Jan 30 '16 at 0:26
  • I did not say that. Read the answer again. – Maximus Jan 30 '16 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.