0

I recently bought an Asus DSL-AC68U modem and a PCE AC68 wireless network adapter for my desktop pc.

Setting up the modem was really easy, and I measured up to 70Mbps with a laptop directly connected with a cable, or via ac wireless.

Installing the network adapter was a little bit messier, I mostly use win10x64 and apparently Asus did not care much to update its drivers for a couple of years old card, but it is now up and running.

On the modem I set up an ftp server and a download server that supports http, torrent, ftp, whatever so that I can download big files overnight and store some data on the ftp server.

Now for the funny part. On my desktop I can browse the net well enough (that's subjective!), given that reception is not really good, but downloading a file is impossible. I konw that displaying a webpage consists of downloading a bunch of files and that's what I do not understand.

If I try to download e.g. the latest ubuntu iso the speed goes quite rapidly from some 100kbps to 0Bps, then the DL fails. But again, browsing is painless and quite fast and of course you don't browse at 0Bps.

You'd say my radio link is bad and I should feel bad, but this is not the case.

I just tried to download the ubuntu 15.10 iso with the router download manager, that took 4 and a half minutes, top speed some 6500KBps, 1.1GB file. After that I copied it to my desktop machine via the ftp router server and it was blazing fast. It took about one and a half, top speed some 12MBps, yep that's faster than the 100Mb cable.

Modem fw is the latest, no fancy options like QoS or whatever enabled, drivers on the pc are the latest. At this point I don't really know what to do next apart ditching both the pieces of equipment and going outside to see the sun.

My question is: does this scenario even make sense to anyone? How is it possible that connection speed is not "bottleneck driven" but "random driven", i.e. why A to B is 12MBps, B to C is 70Mbps but A to C is ~0Bps only when downloading files but not browsing the net?

1
  • I understand that the question as-is is a bit borderline for a sx community. I am more than willing to help troubleshooting the issue, editing the question to add meaningful procedures and infos and accept the answer that explains what the hell is going on. I hope that's okay for you guys. Jan 23 '16 at 11:01
0

Apparently this issue is a well known bug of th Asus AC68U router, and it seems to be present mainly with Italian ISPs, only over wifi and only with windows clients.

This is a very difficult problem to diagnose, so if you are having generic WiFi issues I strongly suggest to follow the instructions below.

There is a workaround though.

On the router main page (accessible usually on 192.168.1.1) click on WAN, then on the pencil icon under Edit PVC, then down in the 802.1Q section thick Yes next to Enable, leaving the other two fields to 0, VLAN ID and 802.1P.

I unfortunately do not have the tinyest clue on how it is possible that a VLAN option can affect internet speed. Only on WiFi. Only with windows clients. Only with Italian ISPs. I am not sure I do want to know.

It is worth mentioning that we had also another odd issue, only on mobile clients, i.e. slow 9gag gif loading. And that option solved it. Yeah that's not a joke.

1
  • I really, really hope that this can help somebody. I spent entire evenings trying to fix this. Jan 28 '16 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.