4

I formatted my MicroSD card to HFS+ and then back to NTFS from within my Phone device (using an app namely Paragon exFAT, NTFS, and HFS+). Now that I insert the card into my PC (Windows 7), the MicroSD card doesn't show up in My Computer folder anymore. I want to initial and format this MicroSD card to NTFS from within my Windows PC.

Windows Disk Management (compmgmt.msc) can detect the pertaining disk with its drive letter nicely, but shows "no media" inserted. So, it is not possible for me to do format operations on it. How can I get my MicroSD card back to the operation again?

Update:

Picture below shows all storage devices currently connected to my PC.

Disk 0 : WDC WD3200BPVT-00HXZT3 ATA Device

Disk 1 : SD/MMC Disk Device

Disk 2 : Ricoh Memory Stick Disk Device

LIST DISK

At the following, DETAIL DISK shows the detailed information for Disk 1; that is my Laptop's SD-Card reader slot. Notice that DISKPART shows No Media although the MicroSD card is actually inserted into the slot.

DETAIL DISK

Also, I get error that the disk is not a GUID Partition Table (GPT) when I try to change GUID for Disk 1; as follows.

UNIQUEID DISK

Although using CLEAN for a disk with no media seems meaningless but I've given it a try as with error: Virtual Disk Service error: There is no media in the device.

CLEAN partition information

  • All comments were deleted by a moderator, but it might be important to salvage the fact that when formatting the card on Windows, the poster reported having encountered cyclic redundancy check errors. This raises the possibility of his having a bad card. – harrymc Jan 27 '16 at 17:12
  • @harrymc I just checked the disk with HDD Regenerator and Eassos PartitionGuru for bad sectors; the whole disk is with bad sectors. I wounder why the disk is working so nicely in my Android devices but not working in Windows PC due to seemingly bad sector problem. Is that my sdcard is set locked / write-protected by a malicious Android app? – DavidDe Feb 2 '16 at 14:16
  • Yes, that can happen. You should use a read-only test. For example chkdsk without the /f parameter. – harrymc Feb 2 '16 at 14:38
  • The type of the file system is RAW. CHKDSK is not available for RAW drives. Okay, how to fix this read-only problem if that is the case? Also, I have erased all the sectors with zero-overwrite but I am stil getting bad-sector report by the said recovery tools. – DavidDe Feb 2 '16 at 15:19
  • You could just give up. If the card was good, the advice below should have fixed it. I'm going to add an answer to that effect. – harrymc Feb 2 '16 at 17:08
3
+50

When formatting the card on Windows, the poster has reported encountering cyclic redundancy check errors on the card.

That, together with the fact that he has tried every other advice given in this thread, seems to point to the fact that the card contains bad sectors, in a place which only Windows accesses.

You could continue to use this card on the phone, but not on Windows. I would still hesitate to recommend this, as there might exist other weak sectors. In any case, even if you decide to use the card, do not trust it.

  • 1
    As one week passed with no effective answer after many discussions and trying many advices, I choose this as answer for temporary. However, I think that the discussion should be shifted towards solutions on sdcard being locked, write-protected by malicious apps, or compatibility issues. Specially because having the sdcard inserted in my Android phone, I scanned it for bad sector from my PC by PartitionGurubut there was no bad sector with the disk. – DavidDe Feb 2 '16 at 23:11
  • Cool deal for sure!! – Pimp Juice IT Jul 11 '17 at 1:03
3

I believe Windows cannot read HFS+ partitions, so you'll look for 3rd parties utilities to format your MicroSD.

I'd like to suggest using MiniTool Partition Wizard http://www.partitionwizard.com/free-partition-manager.html. It helped me overcome many difficulties that occur with Windows partition utility. Format your deficient MicroSD using the Format and Apply buttons.

Another solution is to write an image of an identical MicroSD card of yours using Win32DiskImager http://sourceforge.net/projects/win32diskimager/, if Windows still is able to detect the drive with a letter.

Use Win32DiskImager to read the image of the spare MicroSD card to your hard drive, then write the same image to your inaccessible MicroSD using the same tool.

Another solution is to use other OSs that recognise HFS+ partitions, most likely many Linux distributions, and from there format your inaccessible MicroSD to NTFS. This sounds like a long solution for your problem, but consider it if the above solutions are not taking you any further.

  • That is TEAMGROUP MicroSD card 16G (SDHC I). To use your 1st recommended tool, I need a recovery image file. Where can I find such image file? – DavidDe Jan 28 '16 at 15:06
  • 1
    @DavidDe you could try one of the images made for single-board computers like Raspberry Pi. For example, this image has a small FAT32 partition with config files, it's visible on Windows when you read the card. – Dmitry Grigoryev Jan 28 '16 at 15:28
  • Ok I'm downloading it – DavidDe Jan 28 '16 at 15:45
  • Now that I am aware of your microSD card type, did you use this tool to format your SDXC card ? sdcard.org/downloads/formatter_4. Please note that you may need an update to read XC cards from here sdcard.org/consumers/sdxc_capabilities/index.html#cards-for-pcs Images may not be found online. Which leaves you 1. to buy identical SD card (which is not cheap, being class 10 SD card) or borrow someone's SD card identical to yours, 2. to format it (using the link in this comment), and then read its image. – Sanny Jan 28 '16 at 15:53
  • @Sanny Images are not SDHC-specific. I have several SDHC cards which work just fine with raspbian/bananian images, created for 2-4 GB cards. – Dmitry Grigoryev Jan 28 '16 at 15:57
2

It looks like you have managed to format the entire device as one partition, without any partition table. This is entirely legit (your phone is using it just fine), but software that expects every disk to have a partition table may "freak out" and refuse to touch the device.

Basically, all you need to do is to convince your computer to recreate the partition table for you. You have several possibilities:

  • if you have access to a Linux machine (booting from a LiveCD should do), you can simply erase the first megabyte of your disk with dd if=/dev/zero of=/dev/sdx count=2048, and then run fdisk or gparted to create a fresh partition table.

  • if you're limited to Windows, get a software capable of reading/writing full disk images ("disk" meaning device, not windows drive). Make an image of a sane SD card (smaller that the one you want to recover), and write that image to the malfunctioning microSD. Your microSD should become readable, though it will have partitions of a smaller card. You'll have to delete those partition and create new ones, to use the microSD's full size.

I'm a Linux guy so I'm having a hard time recommending a suitable Windows tool. Judging by the description, Acronis seems suitable.

PS: as you may have guessed, both techniques will nuke all contents of the microSD card, so back up useful data before trying them.

  • Thanks for your reply. I am not a Linux guy but I have busybox installed on my phone. Is dd if=/dev/zero of=/dev/sdx count=2048 can be executed by busybox for Android? What do you mean of fdisk? Is that an Android app? – DavidDe Jan 27 '16 at 14:37
  • If your phone is rooted, try doing dd if=/dev/zero of=/dev/sdx count=2048 from busybox console. I'd expect even Windows will be able to see a clean unpartitioned drive after you zero out the partition table. If your phone is not rooted, such command will most probably fail. Also, you'll have to find out the device name first. On PCs, it's usually /dev/sda, /dev/sdb etc, depending on how many drives you have. On mobile platforms, your sd card may as well be called /dev/mmcblk0, /dev/mmcblk1 etc. mount command (again inside busybox) should give you device names. – Dmitry Grigoryev Jan 27 '16 at 14:42
  • There are /dev/block/mmcblk0 , /dev/block/mmcblk0pX where X=1-10; and /dev/block/mmcblk1 and /dev/block/mmcblk1p1 . I am not sure which is one that you are referring to. FYI, my MicroSD's path is /storage/sdcard1 so I guess that I should use either mmcblk1 or mmcblk1p1 in your piece of code. Please help me on this. – DavidDe Jan 27 '16 at 23:22
  • Warning: Names of mounted partitions and device names are not nessecary identical. It might very well be /dev/block/mmcblk0 and /storage/sdcard1. – Hennes Jan 28 '16 at 14:17
  • @Hennes, I am afriad that mmcblk0 is reffering to the my phone's internal storage. However, I tried busybox dd if=/dev/zero of=/dev/block/mmcblk1; after that AParted couldn't detect the MicroSD card. – DavidDe Jan 28 '16 at 14:42
0

Try inserting the sd-card into your android phone or tablet and format it to FAT32 format. Then check if it is recognized by the PC. If it is then format it to NTFS using the PC.

Can't Comment(Not enough points)...

  • I have already tried this but to no avail. My phone or tablet successfully formats (FAT32) the damaged sd-card but when I remove this MicroSD card from the phone and then to insert it into my PC card-reader slot, Windows doesn't detect MicroSD card inserted. Surperisingly, only if I connect my Phone (with MicroSD card installed) to PC via USB cable with Mass Storage Device option, Windows can detect and access this MicroSD card from the phone. – DavidDe Jan 27 '16 at 13:46
  • try the answer provide here - ccm.net/forum/… – Rico Jan 27 '16 at 13:50
  • As phone (with this MicroSD card installed in the phone) connected to PC via USB as Mass Storage Device, I try to reformat the card from PC (as if it is inserted to PC card-reader slot) but I get errors DiskPart has encountered an error: Access is denied.' or You do not have suffcient rights to performe this operation.' Yes, Windows command-prompt's been already started as Administrator. – DavidDe Jan 27 '16 at 13:52
  • @DavidDe Try below steps.Plug it in as mass storage device. 1. Open Start -> Run... 2. type diskmgmt.msc and press enter 3. right click on the partition you want to format (where the letter and size is) 4. select 'Delete Partition...' and confirm 5. right mose button in the same place and select 'Create partition' 6. select primary partition 6. select size, file format, disk letter, label etc should be all right if you leave defaults. 7. click ok – Rico Jan 27 '16 at 13:58
  • DISKPART and Disk Management are same tools. BTW, there is not partition for my MicroSD card. It is in RAW format. See the comments, I just added below @harrymc above. – DavidDe Jan 27 '16 at 14:17
0

Similar thing happened to me just now. Used SD Card Formatter from the actual SD Card Org. The laptop went to sleep while formatting the card and later never finished when I woke it up. Tried most of the answers above and nothing worked the Partition MiniTool stayed on the splash screen untill taking the card out of the reader. What actually solved my problem is my old Nikon digital camera. Plugged the card in and formatted it using the menu option. Now the card has a fat32 and works as a charm. Just find a device that can erase your card. Cheers!

  • This sounds like another workaround huh? – Pimp Juice IT Jul 11 '17 at 1:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.