0

This is the story:
I have (or should I say had?) Windows 7 "home basic" edition, service pack 1 installed (preinstalled from factory). One day I installed two Linux OS: First Debian 8.3 Jessie and later Ubuntu 14 LTD. Windows still worked perfectly. Notoriously, when I installed Debian the bootloader was changed, grub 2 was installed, and when I installed Ubuntu after that, Ubuntu changed it for Grub 2 (but probably another version) with another background color. All OS worked, except Windows was very slow. Instead of trying to maintain it using i.e. CCleaner, I did a back up and prepared to "restore completely" Windows 7 to a disk image stored from 2012 (I did this 2 days ago) using a program that comes with samsung called "Samsung Recovery Solution 5.0.1.0".

The process went fine until a point in wich asked to reboot the computer (and asked to wait up to 10 minutes depending on the machine) but it did not follow properly, and I know it because in this video another guy does it and his process went differently.

In that video, my process is the same from 0:00 to 3:12 , and inmediately after that, also like in the video it asked for permission to reboot the pc, same dialog as the video (is the 3:15 dialog).

But after that, instead of rebooting and booting into Windows 7 initial configuration interface, it went into Grub, my bootloader, with the familiar screen to choose OS. I choose Windows to see if it worked and this message was displayed:

error: no such device: xxxxxxxxxxxxxxxxxxxxxxxxx error: disk `hotdisk//dev/sda,msdos1'

Press any key to continue...

(xxxxxxxxxxxxxx....) is a number with letters, it just a generic code, doesn't make sense to me to write it for you.

That message had the background color of Grub. After that I pressed key and returned to bootloader main menu to choose OS. I tried again and same errors. I can't boot into Windows anymore. I can, without any problem boot to Debian, and from it I see that my Windows partition was effectively restored, so there is probably some boot loading error that can be fixed.

What can I do to boot Windows normally again? What these errors mean? I don't have evidence this error where cause by dual booting my system, but I regard as possible that installing the two Linux distros and changing boot loader confused the "samsung recovery solution". I hope it's fixable.

EDIT: When writing this question I didn't thought, this was important, but before reading what answer worked for me, realize this: Ubuntu actually got corrupted during a update 2 weeks ago, before this problem. I had to uninstall it with "Boot Repair". So grub returned to the Debian version (the grub that come installed with Debian) . With this information my own answer will make more sense.

0

My problem was solved accidentally by reinstalling Ubuntu amd-64 14 LTD, wich reinstalled GRub, that probably was the fix, I saw somewhere that this a problem similar to mine was installed reinstalling Grub I think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.