3

I'm using WiFi connections or a 3G modem to connect to the Internet, but sometimes the connections break and the LAN settings change to use a proxy server. I have never set a proxy server, and I do not want one.

I set it to Automatically detect settings:

enter image description here

But they somehow get changed back to using a proxy server, without my permission:

enter image description here

Notice the "some settings are managed by your system administrator" banner. Here are the advanced settings : where i have reset and restore them all :

Advanced settings that i set to default

I have tried rebooting, and other solutions on the Internet:

  1. I have deleted HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU to leave only the "default" entry.
  2. I have tried other solutions from Microsoft forums

How can I keep my network settings as they should be?

UPDATE 1 Here is a screenshot when clicking on advanced : Advanced settings

| |
  • @DanielB i have added a capture but i have also restore and reset those settings , ans the problem still persist – The Beast Jan 27 '16 at 9:33
  • Hm, somehow my comment disappeared. Whatever. That wasn’t what I’m referring to. On the proxy settings dialog (“Local Area Network (LAN) Settings”), click the “Advanced” button when the “Use a proxy server for your LAN” checkbox is checked. – Daniel B Jan 27 '16 at 11:47
  • @DanielB yes ok and after that what i should do ? – The Beast Mar 6 '16 at 13:05
  • Provide a screenshot. :D – Daniel B Mar 6 '16 at 15:17
  • @DanielB ok i have added one but i have changed to automatically detect settings when i have boot up my laptop so they can be different ... but the settings as usual will switch back to proxy mode ... then i will verify if the settings stayed the same – The Beast Mar 6 '16 at 16:33
1

As you chose 'Automatically Detect Settings', it does just that, and the dedicated connection point in the LAN has a script ready that will run. As soon as you save, that script probably changes the setting to something different - in your case to 'use a proxy server'.

If you choose none of the check boxes, it will not ask for that script or execute it (but then your LAN might not work...)

I have the same issue whenever I connect from outside the company network, because the company network sets the setting (stupidly) to use a specific script (instead of leaving it on automatic), and the server this script is located on is not reachable from outside the company network. So I have to remove that setting manually every time I want to connect from outside.

| |
  • I don’t see any relation to the question...? His question is about the settings reverting after saving. – Daniel B Jan 24 '16 at 20:46
  • I marked the part in italics. – Aganju Jan 24 '16 at 22:38
  • 1
    That’s simply not true. The PAC script is run every time, because it can direct you to a new proxy on each connection. It can do more than the static options. – Daniel B Jan 25 '16 at 7:15
  • @Aganju it must be something we can do !!! this issue really disturb me – The Beast Jan 27 '16 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.