0

When I connect both to Fortinet SSL VPN and to Cisco VPN at the same time, I cannot use network provided by Forticlient (i.e. my PC cant see remote hosts, ping timeouts). Cisco VPN network works fine though. When I disconnect Cisco VPN, I can ping network resources again, can connect via RDP ans so on. Reproducing in 100% cases, very easy to catch (but not to find underlying issue with skills I have).

Microsoft Windows 10 Pro x64
Forticlient 5.4.0.0780
Cisco Systems VPN Client 5.0.07.0440

My setup is mostly identical to what I had in previous Windows versions. But there is one important difference related to CiscoVPN. It doesn't work in 10 out of the box so I followed this guide: http://www.gleescape.com/posts/2917.

  1. Installed Sonic VPN (it added DNE filter to all network adapters).
  2. Changed registry key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CVirtA" as described (removed '@oem8.inf,%CVirtA_Desc%;' from beginning).

Same result with disabled Firewall and HIPS (provided by Comodo). Windows Firewall is always disabled. I tried to make routing table same as without Cisco VPN (it adds routes when connected) bu it didn't help.

This problem is relevant only for Windows 10 (before and after Threshold 2). I had no problems with Windows 7 and Windows 8.1. Also I had to reinstall Windows 10 once but problem reoccurred after clean install (i.e. it didn't ever work on Windows 10 for me). I browsed sqlite db "C:\Program Files (x86)\Fortinet\FortiClient\logs\fclog.dat". There are no entries for the time when I reproduce issue. There are no relevant windows events (I checked system and applications log). The only event related to network:

<System>
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<Provider Name="BROWSER" /> 
<EventID Qualifiers="16384">8033</EventID> 
<Level>4</Level> 
<Task>0</Task> 
<Keywords>0x80000000000000</Keywords> 
<TimeCreated SystemTime="2016-01-24T08:57:04.695616600Z" /> 
<EventRecordID>36757</EventRecordID> 
<Channel>System</Channel> 
<Computer>GROBIK2015</Computer> 
<Security /> 
</System>
<EventData>
<Data>\Device\NetBT_Tcpip_{64DBF048-CBFA-4B32-8851-B7CE04C06F91}</Data> 
</EventData>
</Event>

I also tried to check network packets with WireShark but this is beyond my knowledge.

I don't know what else to check so I will appreciate any suggestions where to dig. I am not an expert with network technologies and VPN in particular but can understand instructions and use required tools. Thanks in advance.

P.S. sorry if my English not correct sometimes.

migrated from serverfault.com Jan 24 '16 at 12:11

This question came from our site for system and network administrators.

0

I had a similar issue after installing FortiClient 5.4. Could not ping or connect to Remote Desktop even though FortiCleint VPN would connect.

After reading your issue and several unrelated ones, I uninstalled Dell SonicWall (only installed to support Cisco 5.0.07) and Cisco 5.0.07 and I was back in business. Not sure which of the two were the cause. Not sure how much this helps if you have to keep the old Cisco client, but perhaps will provide a avenue for searching for a workable solution.

  • Well, I don't need to uninstall Cisco VPN to have it working - Forti network becomes available immediately when I disconnect Cisco. But you're right, I need them both connected at the same time quite often. – alxK Feb 22 '16 at 13:51
  • @alxK Both of these clients throw default gateway to their respective VPN remote site. Whichever has the least priority determines which network remains accessible. So, you either need to provide routes yourself, that is, one subnet to one gw, another subnet to another gw, or find settings that would not make all traffic go through either VPN. – Vesper Jun 22 '17 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.