(Moved from stackoverflow.com)
I have a computer running the old
Ubuntu 8.04 LTS.
As well as
8.04, the next LTS version,
10.04 is also no longer supported.
There is no published path of direct upgrade from
8.04 -> 12.04.
If I try the standard normal upgrade instruction, I get an error with Python.
Ubuntu 8.04 comes with
Python 2.5. In this error message, "Precise" is the nickname of
stewart@old-ubuntu-box:~$ sudo do-release-upgrade Checking for a new ubuntu release Done Upgrade tool signature Done Upgrade tool Done downloading authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg' extracting 'precise.tar.gz' /tmp/tmpwfCGnZ/DistUpgradeMain.py:102: Warning: 'with' will become a reserved keyword in Python 2.6 Traceback (most recent call last): File "/tmp/tmpwfCGnZ/precise", line 3, in <module> from DistUpgradeMain import main File "/tmp/tmpwfCGnZ/DistUpgradeMain.py", line 102 with open(fname, "a"): ^ SyntaxError: invalid syntax
If I try to upgrade Python to
2.7, to support running of the upgrade, I find dependency problems because I'm still only on
stewart@old-ubuntu-box:~$ sudo apt-get install python2.6 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation: The following packages have unmet dependencies. python2.6: Depends: python2.6-minimal (= 2.6.5-1ubuntu7~lts1) but it is not going to be installed Depends: libc6 (>= 2.11) but 2.7-10ubuntu8.3 is to be installed Depends: libdb4.8 but it is not installable Depends: libreadline6 (>= 6.0) but it is not installable Depends: libsqlite3-0 (>= 3.6.22) but 3.4.2-2 is to be installed E: Broken packages
It's a circular catch-22. Ideally, I should be able to install the correct versions of these broken dependencies (
libc6, etc), but chasing down how to do this for an unsupported release has been elusive.
Any suggestions how to escape / tackle this?
I've managed to upgrade Python using
make install from instructions found here, however, the Python error upon
do-release-upgrade is identical.