1

(Moved from stackoverflow.com)


I have a computer running the old Ubuntu 8.04 LTS.

As well as 8.04, the next LTS version, 10.04 is also no longer supported.

There is no published path of direct upgrade from 8.04 -> 12.04.

There is published a path from 8.04 -> 10.04 and thence a path from 10.04 -> 12.04

If I try the standard normal upgrade instruction, I get an error with Python. Ubuntu 8.04 comes with Python 2.5. In this error message, "Precise" is the nickname of Ubuntu 12.04.

stewart@old-ubuntu-box:~$ sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg'
extracting 'precise.tar.gz'
/tmp/tmpwfCGnZ/DistUpgradeMain.py:102: Warning: 'with' will become a reserved keyword in Python 2.6
Traceback (most recent call last):
  File "/tmp/tmpwfCGnZ/precise", line 3, in <module>
    from DistUpgradeMain import main
  File "/tmp/tmpwfCGnZ/DistUpgradeMain.py", line 102
    with open(fname, "a"):
            ^
SyntaxError: invalid syntax

If I try to upgrade Python to 2.6 or 2.7, to support running of the upgrade, I find dependency problems because I'm still only on 8.04.

stewart@old-ubuntu-box:~$ sudo apt-get install python2.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  python2.6: Depends: python2.6-minimal (= 2.6.5-1ubuntu7~lts1) but it is not going to be installed
             Depends: libc6 (>= 2.11) but 2.7-10ubuntu8.3 is to be installed
             Depends: libdb4.8 but it is not installable
             Depends: libreadline6 (>= 6.0) but it is not installable
             Depends: libsqlite3-0 (>= 3.6.22) but 3.4.2-2 is to be installed
E: Broken packages

It's a circular catch-22. Ideally, I should be able to install the correct versions of these broken dependencies (libc6, etc), but chasing down how to do this for an unsupported release has been elusive.

Any suggestions how to escape / tackle this?


Update:

I've managed to upgrade Python using make install from instructions found here, however, the Python error upon do-release-upgrade is identical.

3
  • 1
    Why don't you just backup your home & config files and do a clean install? And 14.04 LTS is out too, 16.04 should be released soon actually too – Xen2050 Jan 25 '16 at 6:58
  • Not keen on a fresh install. I may have to, but I've got all kinds of additional stuff installed which I would need to make sure of. – Stewart Jan 25 '16 at 9:35
  • Sooner or later a backup & re-install is usually required... Programs in the repos or ppa's could be re-installed with 1 or 2 lines, just keep a copy of the config files if they're not in /home. Then could even try out newer versions of probably an Ubuntu-based distro, or of no ppa's then any Debian-based – Xen2050 Jan 26 '16 at 1:35
2

You could try using apt-get dist-upgrade. Before that, edit /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted

Then sudo apt-get update and sudo apt-get dist-upgrade. If this succeeeds, then reboot and hopefully do-release-upgrade now works for 10.04 -> 12.04.

This is probably not the way it is recommended to be done. I did not find a way how to make do-release-upgrade to do this.

If the upgrade process is interrupted for some reason, commands

dpkg --configure --pending
apt-get install -f

may be useful.

1
  • Also, similar lines for universe and multiverse if needed. – J.J. Hakala Jan 25 '16 at 1:36
1

I suggest that if possible you try using the approach given at https://help.ubuntu.com/community/LucidUpgrades#Upgrading_Using_the_Alternate_CD.2FDVD

Having experienced the problem described in this question, I was subsequently able to upgrade from 8.04 to 10.04 successfully by approximately following those instructions: I burned a CD of the image at http://old-releases.ubuntu.com/releases/lucid/ubuntu-10.04.4-alternate-amd64.iso , mounted it using sudo mount /dev/sr0 /cdrom (your device name may vary!), and ran the upgrade with sudo sh /cdrom/cdromupgrade. This completed successfully. This should also work if you simply mount the image using a loopback device as per the instructions given.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.