6

Installing the new Kali Linux 2016 rolling release to the HDD via USB.

I made a bootable USB using Universal USB. Booted off the USB and selected "Graphical Install", I had an issue at the beginning with the install prompting that it cannot find the data in the CDROM, I pulled the USB and waited 30 seconds, plugged it in waited 30 seconds then plugged it in and it allowed me to continue through the install.

I enabled LVM and went through that whole process once it was done it went to the next step which is "Install the system" at this point I get the error

Debootstrap Error Failed to determine the codename for the release

At this point I cannot go further in the installation. I went back to the "Debian installer menu" and executed a shell. With that shell I tried to mount the USB to /cdrom using "mount -t vfat /dev/sdb1 /cdrom" which I found on a Debian forum. I receive the following error "mounting /dev/sdb1 on /cdrom failed: no such file or directory" I then try to mkdir CDROM, but it states it already exists. sdb1 is my USB according to "mount"

I am not sure what to do at this point. Any advice would be great. Thanks.

0

I had the same issue installing Kali Linux from USB. I tried to install the OS with the graphical install and the simple install. The latter worked without error. It went straight to the "installing the system" screen.

I've found some information on the USB Stick might be bad. For some people changing the USB stick helped. It did not help for me. I got the same error with 3 USB Sticks, and a HDD with 2TB space on it, with a boot partition of 100 GB.

0

I had multiple problems installing Kali including this one. So this is what I did:

I chose manual partition, selected the partition in which I was going to install the ext4 file system (/root) and I deleted all the data of the partition. It took longer than I expected to delete the data, but after that I went back, selected again that partition to install the system, the swap one (I never choose a /home directory since once of the nfts is enough to me) and everything worked like a charm.

That partition had a previous Linux installation, and I'm guessing that was what caused my problems until I deleted all the data.

  • Are you saying you used the same partition for /root, /home, and /swap? It's unclear from your answer. – music2myear May 18 '17 at 16:57
0

This question is old but I just came across a working fix for this.

As it turns out, the issue was caused due to the USB drive being unmounted during the LVM setup process. It might've been a bad USB connector or USB drive.

There is a very easy fix for which you don't even have to reboot or re-do any of the setup again.

  1. Press esc to enter the menu of the installer.
  2. Select Enter a shell (or command prompt)
  3. Run fdisk -l to find out the name and partition of your USB install drive
  4. Run mount /dev/sdc1 /cdrom (replace sdc1 with your USB drive)
  5. Run exit, then go back to Install the base system from the menu

It will continue to install as normal. All credits and thanks go to this guy

Not the answer you're looking for? Browse other questions tagged or ask your own question.