I somehow screw up my iTerm configuration. Now I click the iTerm icon, it shows the menu bar and icon on the dock, but it won't pop up any windows.

So I did:

  • remove it from /Application and reinstall it,
  • remove the ~/Library/Application Support/iTerm,

but that does not solve my problem.

Any other ideas please?


5 Answers 5


Here's a quote from the iTerm page:

Where does iTerm store its settings?

Since version 0.8.0, all the setting is stored in ~/Library/Preferences/iTerm.plist. In case something goes wrong, you can delete this file and iTerm will generate a new settings file that should always work.

Quit iTerm before you delete the preferences file and when you restart, it should be OK.



None of the other solutions worked for me. This is from the new FAQ page:

defaults delete com.googlecode.iterm2
  • To delete run: rm ~/Library/Preferences/com.googlecode.iterm2.plist Jan 11, 2022 at 13:13

iterm2 settings are stored in ~/Library/Preferences/com.googlecode.iterm2.plist. Removing that file will allow the program to reset to the defaults.


I had some problems (it was hanging on a paste of one normal character), and the following rm solved it for me.

rm -rf ~/Library/Application\ Support/iTerm/

There may be a preferences file that also needs to be deleted, from the following directory:


Not sure what it is called for iTerm, but it is likely to be something like:


Don't delete the whole directory, though!

  • BE CAREFUL don't delete the entire directory. To find the other files you need to delete, use an uninstaller like AppZapper. Jul 21, 2009 at 23:06
  • Yes, sorry I didn't make that clear! Jul 22, 2009 at 3:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .