0

I downloaded Node from this link: NodeJS ARM7l and I followed these directions regarding dh_make: tutorial

At the end I run:

dpkg -i ~/Builds/Node/node_5.5.0-1_armhf.deb

and I get:

Selecting previously unselected package node.
(Reading database ... 31155 files and directories currently installed.)
Preparing to unpack .../Node/node_5.5.0-1_armhf.deb ...
Unpacking node (5.5.0-1) ...
Setting up node (5.5.0-1) ...

but when I run:

node -v

I get:

-bash: node: command not found

I tried sudo apt-get -f install and install -f after the dpkg -i command.

I can see it when I run dpkg -l (node 5.0)

Did node not compile correctly? Using Raspbian on Raspberry Pi B.

  • Did you tried to install from source? Can you locate where is the executable? – DrakaSAN Jan 26 '16 at 11:57
  • The post you re following date from 2009, could you try with the instruction from readme.md (which is in the .tar.gz), while it will not be with dpkg, it can help locate where the install fail. – DrakaSAN Jan 27 '16 at 5:21
  • What I downloaded from their ARMv7l repository did not work. I had to compile from source. However, npm did not compile along with it. Not such a big deal; I just have to manually copy over modules that I installed on another system (since they're all just js). Thank you for your time! – allegory Jan 28 '16 at 15:50
  • Good to know you suceeded in compiling it, when I had to install node on a RPi two year ago, it was a real pain to do :). You could consider trying to ask this on RPi.SE, and may found some useful knowledge too. – DrakaSAN Jan 28 '16 at 20:30
0

I don't know raspbian very well but isn't node in the repository somewhere? So just downloadable using apt-get install node? If not, please check the following things:

  • Is the file actually there? It should be in /usr/sbin or /sbin or something.
  • Is the file (node) marked as executable?
  • Is the file location (for instance /usr/sbin) present in your $PATH?
  • Do U maybe need root rights? do: sudo node
  • Raspbian (as well as Debian) repo are out of date for node.js, and has been since it s creation, so apt-get is not a good solution. – DrakaSAN Jan 26 '16 at 11:56
  • Yes @DrakaSAN the Raspbian repos are way out of date for what I would like to do with node.js. The file is there, I have permissions. I have tried sudo as well, same result. When I try executing node or npm from the local untarrd folder ./node or ./npm I get either a seg fault or and illegal instruction. I have tried both v5 and v4.2 nodejs armv7l. Currently I am trying to make them (cross make from on arch to another) but I get a strange error on make: g++: error: unrecognized command line option ‘-mfpu=vfp’ g++: error: unrecognized command line option ‘-marm’ – allegory Jan 27 '16 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.