2

I want to store my user folders (Documents, Pictures, Music, Downloads, etc.) on a Network Shared Drive and Map them as a Network Share on a windows server.

IE. \Server\User is Mapped to U:\ in Windows, then I map Documents to U:\Documents

This works until is require Administrative Privileges to Run a Downloaded Program (Such as Driver Updates or to Install a Browser).

I then get an accessed denied error as the Administrator account does not have access to the Network Share (It is Password Protected and limited to be access to only one user account on the server).

I have tried Enabling and Logging In to the administrator account and adding the credentials to the Credential Manager, but this does not rectify the problem.

Does anyone know a way around this or a better way of setting this up.

Please Note. I Do not want to join this PC to a Domain.

2

I Believe i have solved it.

Ended up finding solution here -> https://support.microsoft.com/en-us/kb/937624

Command Prompt as Administrator -> Ran net use \\<computername>\<sharename> /user:<username>

Then Entered the Password & Remapped the drive.

Note: You will have to disconnect the network drive and remove credentials from Credential Manager and Restart the Computer if it is currently mapped and/or connected to the network path.

I will test if this is required, but this step was also performed.

create and/or set the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections DWORD flag to 1, and then reboot your machine.

See comments below for more details.

  • Or maybe EnableLinkedConnections - see for example Command Prompt in Administrator mode doesn't see mapped drives. It's not entirely clear from the OP what the problem really is. – dxiv Jan 26 '16 at 5:08
  • This was the first thing i tried. It did not work on windows 10 for me. From what i have read it did not work on windows 8.1 either. It does work on windows 7/vista/xp - I am unsure if it works on 8, reports are mixed. – Mike Pengelly Jan 26 '16 at 5:10
  • It does work for me on Windows 10. But your original post mentions some domain and limited to be access to only one user account which I am not sure what really mean. – dxiv Jan 26 '16 at 5:18
  • Basically - There is a user account on the server and the network share has windows permissions defined so only that user can access the files in the folder, this translates over to the network share so that the both the Mapped Network Drive and The credentials need to be shared with the Administrator account. This would differ from a home NAS where generally there is no file permissions so everyone can access the files. It may work if you just need the Mapped Network Drive, i did notice the error message change from 'Unable to Locate' to Permission Denied. It is possible both are required. – Mike Pengelly Jan 26 '16 at 5:51
  • FWIW I have EnableLinkedConnections working both on the home network (classic user/pwd based sharing, no homegroup or simple file sharing) and via VPN into a remote domain-based network. – dxiv Jan 26 '16 at 6:08
0

I solved these kind of problems by creating a batch file that is launched at user logon through a scheduled task.

You create 2 tasks one that is executed under normal privs and 1 that is executed with elevated privs. By this you automate the process and all apps (elevated or not) will be granted access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.