I've got an install of OSX El Capitan running in Virtualbox for so I can test Xcode and potentialy start developing.

I cant seem to log in to the app store though as it appears the serialnumber is set to 0.

Is there a way of setting the serial number in the config files of Virtualbox?

Thanks in advance for any help.

  • 1
    Possible duplicate: superuser.com/questions/55561/…
    – Jonno
    Jan 26, 2016 at 12:22
  • How would you set it to any valid number? There is no valid number for a VB of OS X because it's against Apple's EULA.
    – Tetsujin
    Jan 31, 2016 at 13:39

2 Answers 2


Check the serial number in about us in VM. If it is not there or it is 0. Then below solution will definitely fix your problem.

VirtualBox does not by default make a serial number available to OS X guests. Of course OS X runs just fine inside VirtualBox running on a Mac even in that case. But due to the serial number being “0” the App Store and Server applications will not work.

The solution is to determine the serial number of the real Mac by opening About This Mac or running System Information. It is an alphanumeric string. On my Mac Pro 5,1 it begins with a letter and is 11 characters long.

In Terminal run the following command substituting the name of your VirtualBox virtual machine and your serial number (all one line):

VBoxManage setextradata “<your-vm-name>” VBoxInternal/Devices/efi/0/Config/DmiSystemSerial “<your-serial-number>“

Make sure you remove the quotes while entering the above command.

Starting up the machine after this change will then present a serial number that matches the base system and applications will function correctly.

This was tested on a Mac Pro 5,1 running 10.10.5 with VirtualBox 5.0.14. The guest was 10.11.3.

  • 1
    You need quotes around the VM name if the VM name contains a space. Sep 11, 2017 at 21:34
  • 1
    If you use a snapshot, you should not forget to actually reboot your virtual Mac or else the changes described here will never show (obvious, but easy to miss), Aug 8, 2018 at 9:13
  • Worked also with Virtual box 6.1.4 Under Debian and MacOS Catalina 10.15.4. I have applied a serial number of my Mac mini (Late 2012). Thx @utsav-dusad :)
    – aNeutrino
    Apr 13, 2020 at 4:20

I had the same problem and got it solved after following a tutorial (The link is off Youtube now) that uses the clover bootloader. Unfortunately there's a catch. You have to go through the bootloader process (pressing F12 and select OS launch button) every time you start up the machine. If you don't follow that you get serial number 0. I don't mind this as I don't restart the guest unless absolutely necessary.

  • This video link isn't working! Apr 5, 2017 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.